I am on linux... but specifying the args in the resin.conf works great for me...

the main difference is that prior to the resin 3.1.x series... the watchdog parent process was not java... and simply passed any arguments passed to it down to the child java process which was actually your application server.

now in the 3.1.x series... the parent process is java as well as the child process... and the way to alter the child process is thru the resin.conf

MORAWETZ Martin wrote:
I use Resin on a windows machine. I tried both specifying the
args in resin.conf and starting Resin with 'httpd.exe args'.
Specifiying them in resin.conf results in: java.net.ConnectException: Connection refused: connect
        at java.net.PlainSocketImpl.socketConnect(Native Method)
        at java.net.PlainSocketImpl.doConnect(PlainSocketImpl.java:333)
at java.net.PlainSocketImpl.connectToAddress(PlainSocketImpl.java:195)
        at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:182)
        at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:366)
        at java.net.Socket.connect(Socket.java:518)
        at java.net.Socket.connect(Socket.java:468)
        at java.net.Socket.<init>(Socket.java:365)
        at java.net.Socket.<init>(Socket.java:179)
        at com.caucho.server.resin.Resin.parseCommandLine(Resin.java:934)
        at com.caucho.server.resin.Resin.main(Resin.java:1341)
Can't connect to parent process through socket 1976
Resin needs to connect to its parent.
[Loaded java.util.IdentityHashMap$KeySet from C:\Programme\Java\jdk1.6.0_02\jre\
[Loaded java.util.IdentityHashMap$IdentityHashMapIterator from C:\Programme\Java
[Loaded java.util.IdentityHashMap$KeyIterator from C:\Programme\Java\jdk1.6.0_02
[Loaded java.io.DeleteOnExitHook from C:\Programme\Java\jdk1.6.0_02\jre\lib\rt.j
Resin doesn't start up. Starting httpd.exe with the args C:\Programme\resin\httpd.exe -Xdebug -Xnoagent -Xrunjdwp:transport=dt_socket,server=y,suspend=n,address=12345 -server a
causes Resin to start up correctly saying
"Listening for transport dt_socket at address: 12345
Resin Professional 3.1.2 (built Wed, 18 Jul 2007 11:30:06 PDT)
Copyright(c) 1998-2007 Caucho Technology.  All rights reserved.
As I wrote before, partly it works, because I can see the Resin Threads in
the Eclipse Debug perspective.
Interesting thow that specifying the arguments in the resin.conf and with
httpd.exe behaves that different.
Regards Martin -----Ursprüngliche Nachricht----- *Von:* [EMAIL PROTECTED] [mailto:[EMAIL PROTECTED] *Im Auftrag von *Shane Cruz
*Gesendet:* Dienstag, 14. August 2007 14:36
*An:* General Discussion for the Resin application server
*Betreff:* Re: [Resin-interest] Debugging Resin Apps in/with Eclipse

    How are you passing the arguments to the JVM?  In Resin 3.0, that
    was done with specifying "args" in httpd.sh.  In Resin 3.1 you
    need to specify the arguments in resin.conf as shown here:




    [mailto:[EMAIL PROTECTED] *On Behalf Of *MORAWETZ
    *Sent:* Tuesday, August 14, 2007 7:09 AM
    *To:* General Discussion for the Resin application server
    *Subject:* [Resin-interest] Debugging Resin Apps in/with Eclipse


    I had two approaches to debug Resin Apps within Eclipse
    which worked for me perfectly with Resin 3.0.x. However
    with Resin 3.1.2 I can't get them to work.

    The first approach was to start Resin with the arguments
    -Xdebug -Xnoagent
    and have in Eclipse Resin as Remote Application configured
    (Run -> Debug -> Remote Application), connection Type Socket.

    The second approach was to start Resin in Eclipse having
    Resin configured as 'Java Application'. To switch from Resin
    3.0.x to Resin 3.1.2 I just had to change the classpath and
    change the main class from
    'com.caucho.server.http.ResinServer' to
    'com.caucho.boot.ResinBoot' (I guess).

    Both approaches show the same result with Resin 3.1.2.
    I see the Resin threads in the debug perspective as usual, I'm able
    to run the application, but Breakpoints don't get recognized
    hence I'm not able to debug.

    Any Ideas?

    Regards Martin

"Diese E-Mail sowie jeglicher Anhang sind vertraulich und ausschließlich für den/die bezeichneten Adressaten bestimmt. Diese Mitteilung kann rechtlich geschützte, firmeninterne oder anderweitig vertrauliche Informationen enthalten, deren Weitergabe ohne unsere Zustimmung strengstens untersagt ist. Sofern Sie nicht der beabsichtigte Adressat sind oder diese E-Mail irrtümlich erhalten haben, sind Sie nicht autorisiert, diese Mitteilung bekanntzumachen, zu kopieren, weiterzugeben oder aufzubewahren. Bitte informieren Sie uns in diesem Fall unverzüglich und vernichten diese E-Mail. Diese Fußnote dient auch der Bestätigung darüber, daß diese E-Mail automatisch auf Computerviren, anstößige Inhalte und Einwahlprogramme gescannt wurde."

"The information in this e-mail and in any attachments is confidential and intended solely for the attention and use of the named addressee(s). This information may be subject to legal, professional or other privilege and further distribution of it is strictly prohibited without our authority. If you are not the intended recipient, you are not authorised to and must not disclose, copy, distribute, or retain this message or any part of it, and should notify us immediately.

This footnote also confirms that this email has been automatically scanned for the presence of computer viruses, profanities and certain file types."
This message has been scanned for viruses and
dangerous content by *MailScanner* <http://www.mailscanner.info/>, and is
believed to be clean.

resin-interest mailing list
resin-interest mailing list

Reply via email to