I'm new to both Eclipse and Resin, so please bear with me!  I'm
attempting to set up the "Improve Resin Plugin" in Eclipse
(The Java EE version with WTP).

I've got it installed, and created a resin project using the wizard.
I've added one jsp and one html file to the project, but when I use
the "run" instructions from the plugin readme file, I get the
following error message:

java.lang.NoClassDefFoundError: com/caucho/server/http/ResinServer
Exception in thread "main"

I have the following installed on my computer:

1. J2EE 5 SDK Update 5
2. Resin 3.1.3 (running)
3. Improve Resin Plugin for Eclipse 3 (installed into eclipse)

I've done the following in Eclipse according to the plugin
instructions found here:

1. Set the preferences under Window/Preferences - Resin
    - put the Eclipse version as 3.x
    - set the Resin Home directory to C:\resin-3.1.3
    - originally I left the Java compiler as blank, since the
instructions say if you are running from a JDK, you don't need to set
this, but when I ran into problems I did set it to
C:\Sun\SDK\jdk\bin\javac.exe, but it made no difference.

I then created a resin project as the plugin readme suggests by
selecting New/Other and creating a resin project.  I added an
index.jsp that uses jsp to include an html file, I went to the "Open
Run Manager" and created a new configuration under "Resin", gave it a
new name and set the configFile path to C:\resin-3.1.3\conf\resin.conf

I tried running it, but I got the error above.  It seems to be looking
for a main class - really weird for a web app!  The readme says
something about changing a classpath, but I have no idea what I should
make it, or how I would set it.  I see that under the run
configuration setup, there is a tab that says classpath, but I'm not
clear how or what I would enter anything there.

The other weird thing I noticed is that in the Package Explorer in
Eclipse, the classes and work files aren't accessible.  If I want to
add something to the WEB-INF/classes folder, I can do that by
selecting new/Folder or new/File and choose to put it under those
directories and it saves it in the file system, but no matter what I
do, it doesn't show up in the Package Explorer.  I've tried
refreshing, but still no luck!  I'm not sure if this is a plugin issue
or an Eclipse issue, but any advice would be greatly appreciated!

Thanks in advance,

resin-interest mailing list

Reply via email to