I'm trying the webapp-versioning feature <
http://caucho.com/resin/doc/webapp-deploy.xtp#web-app%20versioning> with
Resin-pro-3.1.s080215 but I have some troubles, either in understanding the
feature and the documentation or in configuring it (or something else ;-)

My resin.conf contains:
      <web-app-deploy path="webapps-versioning" versioning="true"/>


At the beginning, the webapps-versioning folder is empty.
I have prepared two .war files, to try the webapp-versioning feature.


1.) foo-1.1.war contains only a index.jsp which consists of:
<%@ page session="true" %>

<pre>
<%= System.currentTimeMillis() %>

This is foo-1.1

<%= application.getRealPath("/")%>
<%= request.getSession() %>
</pre>



2.) foo-1.2.war contains only a index.jsp which consists of:
<%@ page session="true" %>

<pre>
<%= System.currentTimeMillis() %>

This is foo-1.2

<%= application.getRealPath("/")%>
<%= request.getSession() %>
</pre>





Now, I've dropped *foo-1.1.war* into webapps-versioning folder and it's
getting expanded and started by Resin.
I browse to http://localhost:8080/foo in my *Safari Browser* and see this:

1203456064640

This is *foo-1.1*

C:\Downloads\resin-pro-3.1.s080215\webapps-versioning\foo-1.1\
SessionImpl[*abclmAtrf69vd_5MDHZGr*,/foo-1.1]


=> The Session abclmAtrf69vd_5MDHZGr is using foo-1.1 as expected.



Next, I've dropped *foo-1.2.war* into webapps-versioning folder
(foo-1.1.waris still present in webapps-versioning folder).
I've opened a different browser (*Firefox*) to ensure that I'll have a
different session and see this:

1203456092078
*
*
This is* foo-1.2*

C:\Downloads\resin-pro-3.1.s080215\webapps-versioning\foo-1.2\
SessionImpl[*abc_kiUOTjAXQaPUCJZGr*,/foo-1.2]


=> The Session abc_kiUOTjAXQaPUCJZGr is using foo-1.2 as expected, great.



Next, I've checked if the first session in *Safari* which *was using foo-1.1i
*s still using foo-1.1. Pressed <F5> Key to refresh, but:

1203456103203

This is *foo-1.2*

C:\Downloads\resin-pro-3.1.s080215\webapps-versioning\foo-1.2\

SessionImpl[*abclmAtrf69vd_5MDHZGr*,/foo-1.2]


=> Well, the Session abclmAtrf69vd_5MDHZGr is now using foo-1.2 - but I've
expected it is still using foo-1.1?

Is my understanding of this feature wrong or can I tweak the configuration
to achive that the first Session (from Safari Browser) will still use
foo-1.1?


Regards,
Steffen
_______________________________________________
resin-interest mailing list
resin-interest@caucho.com
http://maillist.caucho.com/mailman/listinfo/resin-interest

Reply via email to