On Wed, Apr 30, 2008 at 11:26:32AM -0700, Bradley Schaefer wrote:
> I upgraded my java to the 1.6 final version that just came out for
> Leopard, and I can't seem to get it to work with my resin pro 3.0.24
> installation.  Trying to load up my app I get an
> UnsupportedClassVersionError .  I cleared out my work directory, and
> my var/cache stuff to be sure that it would try to recompile my
> classes, but that didn't have any noticeable effect.  The line it's
> barfing on is the beginning of a listener declaration (as follows):
>     <listener>
>         <listener-class>
>             com.bebo.servlet.ContextListener
>         </listener-class>
>     </listener>
> And the full stack trace that I'm getting is:
> WEB-INF/web.xml:143: java.lang.UnsupportedClassVersionError: Bad version
> number in .class file

Hi Bradley,

Try deleting any autogenerated .class files from your application.  It's
likely that you have some application class files that were compiled
using your old JDK, but since the source files haven't changed, Resin
isn't doing a recompile.



Emil Ong
Chief Evangelist
Caucho Technology, Inc.
Tel. (858) 456-0300

Caucho: Reliable Open Source
--> Resin: application server
--> Quercus: PHP in Java
--> Hessian Web Services

Visit us at booth #518 at the JavaOne Conference, San Francisco, May 6-8

resin-interest mailing list

Reply via email to