Well, I've worked around the problem, but I don't understand it. I was  
using the maven ant plugin to fetch dependencies. One of them was a  
springframework jar, which depended on a version of spring-beans. When  
I put in an explicit request for spring-beans (most recent version),  
the problem went away.

What I don't understand is why it worked just fine in two other  
installations, running the exact same deployment (of the webapp).

On Mar 12, 2009, at 23:06:58, Rick Mann wrote:

> Hi. I've been setting up a new server, and I decided to go with resin
> 3.2.1. It seemed to install and run fine, but when I added my webapp,
> I'm getting a series of odd errors.
> [03-12 21:42:39.149] {http--8080-3} Caused by:
> org.springframework.beans.factory.BeanCreationException: Error
> creating bean with name 'service' defined in ServletContext resource  
> [/
> WEB-INF/config/springContext.xml]: Invocation of init method failed;
> nested exception is java.lang.NoSuchMethodError:
> org.springframework.util.ClassUtils.getAllInterfacesForClass(Ljava/
> lang/Class;Ljava/lang/ClassLoader;)[Ljava/lang/Class;
> I don't get any class not found errors (I did, until I remembered to
> set the tree-loader for my apps). This same app runs just fine on
> resin 3.1.5 and 3.0.23. I know it's finding at least some of my jars,
> because before the tree-loader, the jdbc driver wouldn't load, and
> afterward, it did.
> I'm kind of at a loss on how to proceed.


resin-interest mailing list

Reply via email to