Things we've tried:
* changing our tasks to implement Runnable vs Work (a swag, as
com.caucho.resources.ScheduledTask operates on Runnables, which work is
* Put breakpoints in com.caucho.resources.ScheduledTask methods including
the init, start, and handleAlarm methods. The debugger breaks on init and
start, but handleAlarm is never called.

Is something killing the alarm service?  Did something change in the
schedule-task tags that require changing syntax in 3.1.9?

The 3.1.8 mem leak issues are a problem for us in production, thus the
desire to move to 3.1.9.



tweihs wrote:
> Bumping this, still seeing the issue with 3.1.9.  We tried to move forward
> to 3.1.9 again today, but all ScheduledTasks would not run.  Reverted to
> 3.1.8 and AOK.
> -tyson
> tweihs wrote:
>> We upgraded to resin 3.1.9 yesterday in our production environment.  The
>> upgrade process for us was simple: unzip the 3.1.9 bundle, copy over the
>> resin.conf, license, other supporting files and restart the server. 
>> However, 3.1.9 will not run any of our scheduled tasks.  The app comes up
>> under 3.1.9, responds to requests, but won't run tasks (I think this
>> carries over to JMS as well, but need to confirm).  Bring the server down
>> and start up in 3.1.8 and schedule tasks resume executing.  
>> I recall when upgrading to 3.1.8 there may have been an issue with some
>> of the Resin generated wrappers/proxies on registered beans that
>> prevented tasks from running, and clearing something (WEB-INF/work, IIRC)
>> ended up unblocking whatever kept ScheduledTasks from running.  We've
>> tried doing clean builds and deploying under clean installs to 3.1.9 and
>> can't get those tasks to run.
>> We experience the exact same behavior in development, stage, and
>> production.
>> Any ideas?
>> -tyson

View this message in context:
Sent from the Resin mailing list archive at

resin-interest mailing list

Reply via email to