Whoa, by total accident I launched my start script without passing "start", like this:


instead of

./resin.sh start

And it seems to run fine when not in "daemon" mode, or whatever Caucho calls it when the server runs in the background. So it's still a mystery what could be causing it to not work when I run with the "start" option.


On 3/19/2010 4:22 PM, Aaron Freeman wrote:
Thanks. That didn't help, so I just stopped using the resin:type feature and through the password in plaintext to see what would happen. Now when I launch resin I get this:

[r...@alpha bin]# ./transfer.3.1.9.sh start
Resin/3.1.9 started -server '' for watchdog at
[r...@alpha bin]# ps awx | grep java
 4388 pts/1    S+     0:00 grep java
[r...@alpha bin]#

It seems like it's starting, but when I ps for the process it never creates the java server process. There are no logs under the ${resin.home} directory to give me a hint as to why it's not starting.

Where else can I look, or what else can I do to see why I can't start the server?



On 3/19/2010 11:41 AM, Rick Mann wrote:
I think what you want to do is add

<library-loader path="/opt/server/java"/>

To your resin.xml. At least, that's how I do it in resin-4.0.x

In 4, you can also add all those Java args in the resin.xml file (I think you can in 3.1, too, but I don't know for sure).

On Mar 19, 2010, at 07:48:27, Aaron Freeman wrote:

Resin version: resin-pro-3.1.9

I am trying to convert my resin-pro-3.0.23 startup scripts and
resin.conf file to work with resin-pro-3.1.9.  It's close, but there is
a small error.  I am trying to build a start script similar to:

$RESIN_HOME/bin/httpd.sh -verbose \
-J-server \
-J-Xmx$JAVA_MX \
-J-Xms$JAVA_MS \
-J-verbose:gc \
-J-XX:MaxGCPauseMillis=5000 \
-J-XX:GCTimeRatio=19 \
-J-XX:+PrintGCTimeStamps \
-J-Djava.security.egd=/dev/urandom \
-J-cp=/opt/server/java/test.jar \
-server-root $SERVER_ROOT \
-Dresin.home=/opt/resin-pro-3.1.9 \
-conf /opt/server/conf/resin.xml \

But when I launch it, it fails on this line in the resin.xml:

/opt/server/conf/resin.xml:41: java.lang.ClassNotFoundException:
Password in EnvironmentClassLoader[]

39: <key-store-type>jks</key-store-type>
40: <key-store-file>/opt/server/security/ssl.kdb</key-store-file>
41: <password resin:type="com.encryption.Password">abcdefgh</password>
42: </jsse-ssl>
43: </http>

How do I set my classpath such that Resin can find the
com.encryption.Password class we have written, which resides in the
test.jar?  I have tried adding -J-cp=... and just setting the CLASSPATH
environment variable in our start script, but not having any luck.  I
also have this in my resin.xml:

<resin xmlns="http://caucho.com/ns/resin";
<log name="" level="info" path="stdout:"/>
<cluster id="">
<library-loader path="/opt/server/java/test.jar"/>



resin-interest mailing list

Reply via email to