I'm having some trouble getting the maven plugin to work. I've been trying with 
various versions of 3.1, and it seems to me that the runtime dependencies from 
maven aren't added to the classpath of the maven plugin. Is there some 
configuration option I've missed? I've tried adding 
<requiresDependencyResolution>runtime</requiresDependencyResolution> to the 
plugin.xml, but that didn't do much. (btw, it seems all the 3.1.* jars in the 
maven repo is labeled 3.1-SNAPSHOT in the manifest pom).

I've also tried the 4.0.9 version, and that gives me
[INFO] [resin:run {execution: default-cli}]
com.caucho.config.ConfigRuntimeException: java.lang.ClassNotFoundException: 
at com.caucho.config.ConfigException.create(ConfigException.java:168)

followed by

Nov 2, 2010 12:04:43 PM com.caucho.server.cluster.Server <init>
WARNING: java.lang.NullPointerException
at com.caucho.util.Alarm.queue(Alarm.java:382)

I've googled, stackoverflowed and decompiled, and I'm still completely lost. 
Any help would be appreciated! For starters, where's the source code for this 
plugin? I couldn't find it in the official svn repo.

Erlend Halvorsen

B | Erlend Halvorsen, Senior Consultant
E | +47 982 19 365, erlend.halvor...@bekk.no<mailto:erlend.halvor...@bekk.no>
K | bekk consulting as, pb. 134 sentrum, 0102 oslo, norway
K | www.bekk.no<http://www.bekk.no>

resin-interest mailing list

Reply via email to