I'm trying to upgrade one of our applications from running 
resin-pro-4.0.12 to resin-prod-4.0.14.
However, we get an error regarding ojdbc settings.

Within the <web-app ...> tag in resin.xml, we have:

<!-- Oracle lib -->
  <library-loader path="/path/to/lib/ojdbc6-"/>
<!-- Oracle settings -->
<resin:include path="/path/to/app/conf/app-jdbc.conf"/>

These files worked fine for resin-pro-4.0.12 and earlier.

Now, however, we get the error message in resin-debug.log:
[2011-01-28 09:27:13.930] {resin-18} /path/to/app/conf/app-jdbc.conf:1: 
com.caucho.sql.DBPool.init(): com.caucho.sql.SQLExceptionWrapper: 
com.caucho.config.ConfigException: '#text' is an unknown attribute of 

        1: <database>
        2:         <jndi-name>jdbc/app</jndi-name>
        3:         <driver>

The /path/to/app/conf/app-jdbc.conf is on the form:

I have also tried to upgrade another app which uses ojdbc14- 
instead of ojdbc6-, but the same error occurs.

Is this a bug, or is there a configuration change I have missed?
Both 4.0.12 and 4.0.14 has been compiled with 64bit Java. I have also 
tried 4.0.13, which resulted in the same error as above.

Halvor Utby
tlf: 22852972

resin-interest mailing list

Reply via email to