We were on a 64 bit Intel Atom single core server running 64 bit Ubuntu 
when the hoster took a disk image and moved it to a dual core 64bit AMD 
server. All seemed ok, we were on resin pro 4.0.23 and the apache 
integration was fine. Some weeks later I tried to update to resin 4.0.27 
in the usual way, by unzipping the source and using ./configure 
--with-apxs=/usr/bin/apxs2; make; make install and found something's 
gone wrong - mod_caucho.so isn't created. I switched back to the 4.0.23 
install, tried the build again and it also failed. The .so created from 
the Atom deploy is the only one I can use.

During the build I now see this:
In file included from /usr/include/features.h:378,
                  from /usr/include/stdlib.h:25,
                  from stream.c:30:
/usr/include/gnu/stubs.h:7:27: error: gnu/stubs-32.h: No such file or 
make[2]: *** [stream.o] Error 1

I searched for this error and wound up installing libc-dev-i386 in 
response to a forum post, which felt wrong - why the 386? In any case, 
it made things worse - I saw messages such as the .o file now being of 
the wrong arch. So I removed it, which brings me back to where I am now.

I'm guessing when I was on the Atom machine i somehow set up the tools 
and buildchain for that arch, and the move has cloned it all ignoring 
the new arch. Is that right? If so, how can I reset things so I can 
build the mod again please?

-- Carl Whalley

resin-interest mailing list

Reply via email to