I've managed to fix this problem, but it is pretty ugly. Somehow python2.3 and python2.4 and gnome stuff is not playing well together. I am not sure why.

This is what I did to fix it:

- Change first line of /usr/bin/revelation to explicitly use python2.4.
- Change first line of /usr/share/revelation/libexec/revelation-applet to explicitly use python2.4. - Copy the file /usr/lib/python2.3/site-packages/gtk-2.0/gnome/applet.py to /var/lib/python-support/python2.4/gtk-2.0/gnome/applet.py. - Created empty file /usr/lib/python2.3/site-packages/gtk-2.0/gnome/__init__.py.

Any better long-term solution would be greatly appreciated.


Gerald Boersma wrote:

I have done an upgrade on my Debian system, and now evelation aborts with the following error on startup:

Traceback (most recent call last):
File "/usr/bin/revelation", line 32, in ?
from revelation import gnomemisc, config, data, datahandler, dialog, entry, io, ui, util File "/usr/lib/python2.3/site-packages/revelation/__init__.py", line 29, in ?
  import gnomemisc
ImportError: could not import gnome.applet

Python2.4 was installed as part of this upgrade, but /usr/bin/python still points to 2.3. Current version of 2.3 is Python 2.3.5 (#2, Jun 13 2006, 23:12:55).

It seems to me that all packages required are in /usr/lib/python2.3/site-packages, so I am not sure what is causing the problem.

Any ideas?



Reply via email to