I did some more looking into this and apparently pkf-config looks for
a file XXX.pc where XXX is the name of the package. I find the
pygtk-2.0 file on my system at:

/usr/lib/pkgconfig/pygtk-2.0.pc

I then tried adding both

/usr/lib
/usr/lib/pkgconfig/

to PKG_CONFIG_PATH and rerun configure, but I still get the same
error. So pkg-config really seems to be acting up here. Any way it can
be overruled in the config process?

On 8/1/06, Mass Dosage <[EMAIL PROTECTED]> wrote:
> Hm, weird. I don't know of any SuSE packages, but you should be able to
> install from source on most modern distros.
>
> Could you post the output from ./configure?

Sure, this is where things go wrong:

-----------

checking pkg-config is at least version 0.9.0... yes
checking for PYGTK... configure: error: Package requirements
(pygtk-2.0 >= 2.3.90) were not met.
Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively you may set the PYGTK_CFLAGS and PYGTK_LIBS environment variables
to avoid the need to call pkg-config.  See the pkg-config man page for
more details.

------------

If I query my RPM datbase I have this version of pygtk installed:

python-gtk-2.8.2-21

So I think it's just pkgconfig which is not detecting the correct
version of pygtk installed in SuSe. I tried pointing the various
environment variables at where pygtk seems to be installed, candidates
on my system are

/usr/share/pygtk/2.0
/usr/lib/pygtk/2.0/

I'm not sure which it should be and which variable should point to
which folder. Any ideas?

PEACE

Mass Dosage


Reply via email to