Issue 700: install' is broken at django-evolution; is  
also broken

New issue report by akimball83:
I tried to install Reviewboard by running 'sudo python install'

This fails when it gets to django-evolution:

[ lots of copying... lines elided ]
Installed /usr/lib/python2.5/site-packages/
Processing dependencies for
Searching for django-evolution
Best match: django-evolution 0.0.0
Processing django_evolution-0.0.0.tar.gz
Running django_evolution-0.0.0/ -q bdist_egg --dist-dir
zip_safe flag not set; analyzing archive contents...
django_evolution.evolve: module references __file__
No eggs found in
/tmp/easy_install-nKmMrt/django_evolution-0.0.0/egg-dist-tmp-blRvBZ (setup
script problem?)
error: Could not find required distribution django-evolution

(it looks like a broken package on your site?)

I installed Django 1.0, python-module-MysqlDB, and memcached, and then ran
the reviewboard installation script. I'm trying to get this to work in
Apache on Fedora Core 8 (x86_64). Python is 2.5.1.

Before attempting, Apache complains in ssl_error_log:
[Tue Oct 21 06:00:22 2008] [error] [client] ImportError:
Could not import settings 'reviewboard.settings' (Is it on sys.path? Does
it have syntax errors?): No module named reviewboard.settings

After the aborted attempt, it now claims:
[Tue Oct 21 03:01:33 2008] [error] [client]
ImproperlyConfigured: Error importing middleware
reviewboard.admin.middleware: "No module named django_evolution"

I also tried running 'autoconf' to try to install this way.
When generating the configure script, it complains: error: possibly undefined macro: AM_INIT_AUTOMAKE
       If this token and others are legitimate, please use m4_pattern_allow.
       See the Autoconf documentation. error: possibly undefined macro: AM_MAINTAINER_MODE error: possibly undefined macro: AM_PATH_PYTHON error: possibly undefined macro: AM_PATH_DJANGO

Running the configure script anyway gives:
./configure: line 1629: syntax error near unexpected token `1.9'
./configure: line 1629: `AM_INIT_AUTOMAKE(1.9 dist-bzip2)'

This is with autoconf-2.61-9.fc8.noarch and automake 1.10

Issue attributes:
        Status: New
        Owner: ----
        Labels: Type-Defect Priority-Medium

You received this message because you are listed in the owner
or CC fields of this issue, or because you starred this issue.
You may adjust your issue notification preferences at:

You received this message because you are subscribed to the Google Groups 
"reviewboard-issues" group.
To post to this group, send email to
To unsubscribe from this group, send email to [EMAIL PROTECTED]
For more options, visit this group at

Reply via email to