Comment #2 on issue 585 by pmclanahan: post-review dies when binaries are  
part of a p4 changeset

I've had this same issue and done some debugging. The problem is on line  
975 and is
caused by that line not evaluating to True. I'm still not sure why this is,  
but for
me on Windows I had thought it was due to line ending issues, but since I  
now see
this other bug report on Linux, I'm not so sure. In any case, the attached  
fixed it for me. I basically replaced the direct string equality check with  
a regex
match. It's possible that just using 'dl[0].startswith()' instead of '=='  
or my regex
would work as well, but I haven't tried that. Maybe this will help mayesgr  
get revews

        post-review.patch  585 bytes

You received this message because you are listed in the owner
or CC fields of this issue, or because you starred this issue.
You may adjust your issue notification preferences at:

You received this message because you are subscribed to the Google Groups 
"reviewboard-issues" group.
To post to this group, send email to
To unsubscribe from this group, send email to
For more options, visit this group at

Reply via email to