Status: New
Owner: ----
Labels: Type-Defect Priority-Medium

New issue 1041 by Jason.Govig: Too easy to lose edits

*NOTE: Do not post confidential information in this bug report.*

What's the URL of the page containing the problem?
Not available

What steps will reproduce the problem?
1. Initiate a new review, for example using post-review
2. Click in the "Description" field and add a bunch of information.
3. Click "Publish" without clicking "OK" first.

What is the expected output? What do you see instead?
I expect the publish to incorporate my new edits.  Instead, it drops the
new text without warning. It should either disable the publish button while
a field is being edited, incorporate the edits automatically, or prompt the
user to continue ("Field 'blah' not saved. Continue?").

What operating system are you using? What browser?
WinXP64 with Firefox 3 and CentOS4.6 64-bit with Firefox 2.

Please provide any additional information below.
A similar issue occurs when editing other fields (e.g., adding reviewers
("People")) and clicking the "diff" link to switch to the diff view without
hitting the enter key to save the field.  In this case, because there is no
"OK" button for that field, I assumed the edits were "live", especially
after a tab-completion. I later figured out that typing the enter key saved
the field.

You received this message because you are listed in the owner
or CC fields of this issue, or because you starred this issue.
You may adjust your issue notification preferences at:

You received this message because you are subscribed to the Google Groups 
"reviewboard-issues" group.
To post to this group, send email to
To unsubscribe from this group, send email to
For more options, visit this group at

Reply via email to