Status: New
Owner: ----
Labels: Type-Defect Priority-Medium

New issue 1232 by e2fung: Installing a site in a subdirectory does not  
display pages formatted with CSS

What version are you running?

What's the URL of the page containing the problem?

What steps will reproduce the problem?
1. Install Review Board site using Apache and mod_python by following
directions at and
specify "/reviews/" for the Root Path.
2. Browse to the site, e.g.";

What is the expected output? What do you see instead?
I expect to see the login screen and Dashboard rendered with CSS. Instead,
I just see plain text.

What operating system are you using? What browser?
Ubuntu Linux 9.04 on x86, Firefox 3.0.11

Please provide any additional information below.
The generated apache-modpython.conf file does not use the specified root
path subdirectory in the virtual host override rules nor in the alias.

I've attached an untested patch that attempts to fix it. I don't know if
Site.site_root defaults to '/' so there may need to be some tweaking of
this patch; I'm also not a Python programmer!

        site-subdir.patch  1.1 KB

You received this message because you are listed in the owner
or CC fields of this issue, or because you starred this issue.
You may adjust your issue notification preferences at:

You received this message because you are subscribed to the Google Groups 
"reviewboard-issues" group.
To post to this group, send email to
To unsubscribe from this group, send email to
For more options, visit this group at

Reply via email to