Comment #6 on issue 957 by keithhoffman22: UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 3: ordinal not in range(128)
http://code.google.com/p/reviewboard/issues/detail?id=957

We've been using reviewboard for a while now but haven't tried to use post-review
before.  I finally have everything configured and get ...

D:\projects-svn\Core>post-review --repository-
url=https://breckenridge.digidata.com/svn/Core --revision-range=171:290
==> Review Board Login Required
Enter username and password for Review Board at
http://breckenridge.digidata.com/reviews/
Username: khoffman
Password:
Traceback (most recent call last):
File "c:\programs\python26\Scripts\post-review-script.py", line 8, in <module>
    load_entry_point('RBTools==0.2rc1', 'console_scripts', 'post-review')()
  File "c:\programs\python26\lib\site-packages\rbtools-0.2rc1-
py2.6.egg\rbtools\postreview.py", line 2774, in main
  File "c:\programs\python26\lib\site-packages\rbtools-0.2rc1-
py2.6.egg\rbtools\postreview.py", line 2480, in tempt_fate
  File "c:\programs\python26\lib\site-packages\rbtools-0.2rc1-
py2.6.egg\rbtools\postreview.py", line 503, in upload_diff
  File "c:\programs\python26\lib\site-packages\rbtools-0.2rc1-
py2.6.egg\rbtools\postreview.py", line 622, in api_post
  File "c:\programs\python26\lib\site-packages\rbtools-0.2rc1-
py2.6.egg\rbtools\postreview.py", line 597, in http_post
  File "c:\programs\python26\lib\site-packages\rbtools-0.2rc1-
py2.6.egg\rbtools\postreview.py", line 656, in _encode_multipart_for
mdata
UnicodeDecodeError: 'ascii' codec can't decode byte 0xef in position 204011: ordinal
not in range(128)

I have no idea what the character is but it seems like a superior behavior would be fix the character or somehow ignore that character (assume no diff etc) but blowing
up and providing a difficult position to locate isn't very helpful

--
You received this message because you are listed in the owner
or CC fields of this issue, or because you starred this issue.
You may adjust your issue notification preferences at:
http://code.google.com/hosting/settings

--
You received this message because you are subscribed to the Google Groups 
"reviewboard-issues" group.
To post to this group, send email to reviewboard-iss...@googlegroups.com.
To unsubscribe from this group, send email to 
reviewboard-issues+unsubscr...@googlegroups.com.
For more options, visit this group at 
http://groups.google.com/group/reviewboard-issues?hl=en.

Reply via email to