Comment #5 on issue 1637 by bweav19: Review Board + perforce can not upload diff

I have the exact same issue, here is my output with debug but not output-diff. As a note this is a brand new reviewboard server and my first time setting it up.

#post-review 513239 --debug
svn info
p4 info
repository info: Path:, Base path: None, Supports changesets: True
p4 counters
Generating diff for changenum 513239
p4 describe -s 513239
Processing edit of //depot/syncsuite/cas/trunk/rpm/build.xml
Writing "//depot/syncsuite/cas/trunk/rpm/build.xml#15" to "/tmp/tmpWRRyXF" p4 print -o /tmp/tmpWRRyXF -q //depot/syncsuite/cas/trunk/rpm/build.xml#15 Writing "//depot/syncsuite/cas/trunk/rpm/build.xml#16" to "/tmp/tmpmqWes7" p4 print -o /tmp/tmpmqWes7 -q //depot/syncsuite/cas/trunk/rpm/build.xml#16
diff -urNp /tmp/tmpWRRyXF /tmp/tmpmqWes7
Looking for ' /reviewboard/' cookie in /root/.post-review-cookies.txt
Loaded valid cookie -- no login required
Attempting to create review request on for 513239 HTTP POSTing to {'repository_path': '', 'changenum': '513239'}
Review request created
Uploading diff, size: 566
HTTP POSTing to {}
Got API Error 105 (HTTP code 200): One or more fields had errors
Error data: {'fields': {'path': ['[Errno 2] No such file or directory']}, 'stat': 'fail', 'err': {'msg': 'One or more fields had errors', 'code': 105}}

Error uploading diff

The generated diff file was empty. This usually means no files were
modified in this change.

Try running with --output-diff and --debug for more information.

Your review request still exists, but the diff is not attached.

You received this message because you are subscribed to the Google Groups 
"reviewboard-issues" group.
To post to this group, send email to
To unsubscribe from this group, send email to
For more options, visit this group at

Reply via email to