Status: New
Owner: ----
Labels: Type-Defect Priority-Medium

New issue 1731 by tim.pinet: Can not create new review when no repository is set

*NOTE: Do not post confidential information in this bug report.*

What version are you running?
-RB 1.0.9

What's the URL of the page containing the problem?
-both web and post-review

What steps will reproduce the problem?
-Since I am using TFS as a repository and RB does not support it, I wanted to manually create diffs (either context or unified) and create a new review using the diff file. I tried creating a new diff in the web interface but that requires that a repository is set. Preferably I would like to use post-review so I can script the TFS checkout/diff/RB post process but post-review seems to rely on a repository working directory as well. I tried using the "post-review --diff-filename=diff.file" but that also relies on the repository. Is there any way to use RB without specifying a repository or what is necessary to enable TFS support?

What is the expected output? What do you see instead?
-expected: review is created
-actual (web): try to upload diff file but no repository (field mandatory). No review created.
-actual (post-review): not a working folder issue. No review created.

What operating system are you using? What browser?
-Windows XP (to test the RB system), Python 2.6, Apache 2.2

Please provide any additional information below.

You received this message because you are subscribed to the Google Groups 
"reviewboard-issues" group.
To post to this group, send email to
To unsubscribe from this group, send email to
For more options, visit this group at

Reply via email to