Status: New
Owner: ----
Labels: Type-Defect Priority-Medium

New issue 1849 by matthew....@intel.com: RBTools-0.2rc1.tar.gz tries to use an unavailable version of setuptools
http://code.google.com/p/reviewboard/issues/detail?id=1849

*NOTE: Do not post confidential information in this bug report.*

What version are you running?
RBTools-0.2rc1

What's the URL of the page containing the problem?
http://downloads.reviewboard.org/releases/RBTools/0.2/ (or N/A)

What steps will reproduce the problem?
1. Download and extract RBTools-0.2rc1.tar.gz onto a system lacking a
recent copy of setuptools
2. Execute: python setup.py build
The system will report:
---------------------------------------------------------------------------
This script requires setuptools version 0.6c8 to run (even to display
help).  I will attempt to download it for you (from
http://pypi.python.org/packages/2.6/s/setuptools/), but
you may need to enable firewall access for this script first.
I will start the download in 15 seconds.

(Note: if this machine does not have network access, please obtain the file

http://pypi.python.org/packages/2.6/s/setuptools/setuptools-0.6c8-py2.6.egg

and place it in this directory before rerunning this script.)
---------------------------------------------------------------------------

The problem is that 0.6c8 is unavailable at http://pypi.python.org/packages/2.6/s/setuptools/. The earliest version is 0.6c9, and the latest version os 0.6c11.

It looks like the old file needs to be updated, possibly from the file: http://peak.telecommunity.com/dist/ez_setup.py which references and contains MD5sums for version 0.6c11.


What is the expected output? What do you see instead?
The building of RBTools should have succeeded, but instead failed because it couldn't find the appropriate version of setup tools.

What operating system are you using? What browser?
N/A

Please provide any additional information below.
I was able to work around this failure by replacing the RBTools' copy of ez_setup.py with the above version from peak.telecommunity.com.



--
You received this message because you are subscribed to the Google Groups 
"reviewboard-issues" group.
To post to this group, send email to reviewboard-iss...@googlegroups.com.
To unsubscribe from this group, send email to 
reviewboard-issues+unsubscr...@googlegroups.com.
For more options, visit this group at 
http://groups.google.com/group/reviewboard-issues?hl=en.

Reply via email to