Status: New
Owner: ----
Labels: Type-Defect Priority-Medium

New issue 1921 by vera1171: Encoding Error for ReviewBoard 1.5 on Windows XP
http://code.google.com/p/reviewboard/issues/detail?id=1921

*NOTE: Do not post confidential information in this bug report.*

What version are you running?
1.5

What's the URL of the page containing the problem?
while adding a new repository

What steps will reproduce the problem?
1.Install ReviewBoard 1.5
2.Create a new repository

What is the expected output? What do you see instead?
create a new repository successfully.Error 500 Page.

What operating system are you using? What browser?
Windows XP in Chinese version + RB 1.5 + Python 2.5 + Apache(Mod_Python) + SVN 1.6.2 + pySVN.FireFox

Please provide any additional information below.
In fact,I have installed RB1.5 and created a repository successfully on several other computer.There was no error occurs.However,While I do the same work on my own computer,the error occurs.

I met the same problem as what this page says:
http://groups.google.com/group/reviewboard/browse_thread/thread/cc142514fc3cfa7e?fwc=1

-------------------------quote-------------------------------------
I've just installed the lastest Review Board on my computer today by
following the url ''http://www.reviewboard.org/docs/manual/1.5/admin/
installation/windows/'.

Everything is fine until I got a 500 error while adding a new
repository.


I chose the Custom+SVN, and input all the necessary fields. Here is
the message I got:


--
Something broke! (Error 500)


It appears something broke when you tried to go to here. This is
either a bug in Review Board or a server configuration error. Please
report this to your administrator.
--


And here is the traceback I got from log file:


--


'utf8' codec can't decode bytes in position 17-18: invalid data. You
passed in 'DLL load failed: \xd5\xd2\xb2\xbb\xb5\xbd
\xd6\xb8\xb6\xa8\xb5\xc4\xb3\xcc\xd0\xf2\xa1\xa3' (<type 'str'>)
Traceback (most recent call last):
  File "d:\python25\lib\site-packages\django-1.2.3-py2.5.egg\django
\core\handlers\base.py", line 100, in get_response
    response = callback(request, *callback_args, **callback_kwargs)
  File "d:\python25\lib\site-packages\django-1.2.3-py2.5.egg\django
\contrib\admin\sites.py", line 512, in root
    return self.model_page(request, *url.split('/', 2))
  File "d:\python25\lib\site-packages\django-1.2.3-py2.5.egg\django
\views\decorators\cache.py", line 69, in _wrapped_view_func
    response = view_func(request, *args, **kwargs)
  File "d:\python25\lib\site-packages\django-1.2.3-py2.5.egg\django
\contrib\admin\sites.py", line 531, in model_page
    return admin_obj(request, rest_of_url)
  File "d:\python25\lib\site-packages\django-1.2.3-py2.5.egg\django
\contrib\admin\options.py", line 1190, in __call__
    return self.add_view(request)
  File "d:\python25\lib\site-packages\django-1.2.3-py2.5.egg\django
\utils\decorators.py", line 21, in _wrapper
    return decorator(bound_func)(*args, **kwargs)
  File "d:\python25\lib\site-packages\django-1.2.3-py2.5.egg\django
\utils\decorators.py", line 76, in _wrapped_view
    response = view_func(request, *args, **kwargs)
  File "d:\python25\lib\site-packages\django-1.2.3-py2.5.egg\django
\utils\decorators.py", line 17, in bound_func
    return func(self, *args2, **kwargs2)
  File "d:\python25\lib\site-packages\django-1.2.3-py2.5.egg\django\db
\transaction.py", line 299, in _commit_on_success
    res = func(*args, **kw)
  File "d:\python25\lib\site-packages\django-1.2.3-py2.5.egg\django
\contrib\admin\options.py", line 777, in add_view
    if form.is_valid():
  File "D:\Python25\lib\site-packages\reviewboard-1.5-py2.5.egg
\reviewboard\scmtools\forms.py", line 578, in is_valid
    return (super(RepositoryForm, self).is_valid() and
  File "D:\Python25\lib\site-packages\django-1.2.3-py2.5.egg\django
\forms\forms.py", line 121, in is_valid
    return self.is_bound and not bool(self.errors)
  File "D:\Python25\lib\site-packages\django-1.2.3-py2.5.egg\django
\forms\forms.py", line 112, in _get_errors
    self.full_clean()
  File "D:\Python25\lib\site-packages\reviewboard-1.5-py2.5.egg
\reviewboard\scmtools\forms.py", line 500, in full_clean
    return super(RepositoryForm, self).full_clean()
  File "D:\Python25\lib\site-packages\django-1.2.3-py2.5.egg\django
\forms\forms.py", line 268, in full_clean
    self._clean_form()
  File "D:\Python25\lib\site-packages\django-1.2.3-py2.5.egg\django
\forms\forms.py", line 296, in _clean_form
    self.cleaned_data = self.clean()
  File "D:\Python25\lib\site-packages\reviewboard-1.5-py2.5.egg
\reviewboard\scmtools\forms.py", line 520, in clean
    self._verify_repository_path()
  File "D:\Python25\lib\site-packages\reviewboard-1.5-py2.5.egg
\reviewboard\scmtools\forms.py", line 684, in _verify_repository_path
    raise forms.ValidationError(e)
  File "d:\python25\lib\site-packages\django-1.2.3-py2.5.egg\django
\core\exceptions.py", line 55, in __init__
    message = force_unicode(message)
  File "d:\python25\lib\site-packages\django-1.2.3-py2.5.egg\django
\utils\encoding.py", line 96, in force_unicode
    errors) for arg in s])
  File "d:\python25\lib\site-packages\django-1.2.3-py2.5.egg\django
\utils\encoding.py", line 88, in force_unicode
    raise DjangoUnicodeDecodeError(s, *e.args)
DjangoUnicodeDecodeError: 'utf8' codec can't decode bytes in position
17-18: invalid data. You passed in 'DLL load failed: \xd5\xd2\xb2\xbb
\xb5\xbd\xd6\xb8\xb6\xa8\xb5\xc4\xb3\xcc\xd0\xf2\xa1\xa3' (<type
'str'>)


--


The hex string of '\xd5\xd2\xb2\xbb\xb5\xbd
\xd6\xb8\xb6\xa8\xb5\xc4\xb3\xcc\xd0\xf2\xa1\xa3' here is Chinese
words which means 'The specified program is not found', but its not
utf-8 encoded.


My environment is Windows XP in Chinese version + RB 1.5 + Python 2.5
+ Apache(Mod_Python) + SVN 1.6.13 + pySVN.


Anyone can help on this?


Thanks,


Travis
-------------------------quote end-------------------------------------


--
You received this message because you are subscribed to the Google Groups 
"reviewboard-issues" group.
To post to this group, send email to reviewboard-iss...@googlegroups.com.
To unsubscribe from this group, send email to 
reviewboard-issues+unsubscr...@googlegroups.com.
For more options, visit this group at 
http://groups.google.com/group/reviewboard-issues?hl=en.

Reply via email to