Status: New
Owner: ----
Labels: Type-Defect Priority-Medium

New issue 1970 by postreview mangles repository path when protocol is part of path

What version are you running?
RBTools 0.3 on ReviewBoard 1.5.1

What steps will reproduce the problem?
1. Create a CVS respository in ReviewBoard using :ext:
2. Checkout code from CVS respository where CVSROOT contains :ext:
3. Modify code and run post-review to generate review request.

What is the expected output? What do you see instead?
The expected output is a successful review request posted on ReviewBoard located at http://hyei6/reviewboard/ for the :ext:cvs-server:/cvsdev/test repository.

[Fail output]
hyei@hyei-desktop-linux:~/workspace/test_branch/testdir$ post-review --server="http://hyei6/reviewboard/";
==> Review Board Login Required
Enter username and password for Review Board at http://hyei6/reviewboard/

There was an error creating this review request.

The repository path "hyei-desktop-linux:exthyei-desktop-linux:cvs-serverhyei-desktop-linux:/cvsdev/test" is not in the
list of known repositories on the server.

Ask the administrator to add this repository to the Review Board server.
For information on adding repositories, please read

What operating system are you using? What browser?
Ubuntu 9.04 (64)

Please provide any additional information below.

I've attached a patch that fixes the issue for me. Instead of looking for the first colon, it looks for the last colon when attempting to replace the host name.

Python 2.6.2 was used.

Attachments:  371 bytes

You received this message because you are subscribed to the Google Groups 
"reviewboard-issues" group.
To post to this group, send email to
To unsubscribe from this group, send email to
For more options, visit this group at

Reply via email to