Status: New
Owner: ----
Labels: Type-Defect Priority-Medium

New issue 2012 by christia...@iathh.de: post-review with changenum not working with mercurial
http://code.google.com/p/reviewboard/issues/detail?id=2012

* NOTE: Do not post confidential information in this bug report. *
*       If you need immediate support, please contact            *
*       reviewbo...@googlegroups.com                             *

What version are you running?
RBTools 0.3.2, RB 1.5.4, mercurial client 1.8, python 2.6


What steps will reproduce the problem?
1. hg outgoing shows changesets, e.g. 684, 685, 686
2. postreview 684

What is the expected output? What do you see instead?
I would expect that a new review request for changeset 684 is posted to the review server.

What operating system are you using? What browser?
Linux Mint Isadora on the client, CentOS 5.5 on reviewboard server


Debug output:
$ post-review -d -n 684
RBTools 0.3.2
Home = /home/christian
hg showconfig
hg root
hg svn info
Using candidate path 'default': 'ssh://hg@srv/repo'
repository info: Path: ssh://hg@srv/repo, Base path: , Supports changesets: False
HTTP GETting api/
HTTP GETting http://10.0.0.168/reviews/api/info/
Using the new web API
hg branch
hg -q outgoing --template b:{branches}
r:{rev}

 default
Found outgoing changeset 684 for branch 'default'
Found outgoing changeset 685 for branch 'default'
Found outgoing changeset 686 for branch 'default'
hg diff -r 683 -r 686 684
There don't seem to be any diffs!

--
You received this message because you are subscribed to the Google Groups 
"reviewboard-issues" group.
To post to this group, send email to reviewboard-issues@googlegroups.com.
To unsubscribe from this group, send email to 
reviewboard-issues+unsubscr...@googlegroups.com.
For more options, visit this group at 
http://groups.google.com/group/reviewboard-issues?hl=en.

Reply via email to