Status: New
Owner: ----
Labels: Type-Defect Priority-Medium

New issue 2088 by Bad error when creating a review with an invalid change number.

* NOTE: Do not post confidential information in this bug report. *
*       If you need immediate support, please contact            *
*                             *

What version are you running?
Review Board 1.5.5

What's the URL of the page containing the problem?

What steps will reproduce the problem?
1. From the dashboard click "New Review Request"
2. Select a (Perforce?) repository and enter a bogus change number and click Create
3. See the "Something Broke!" page and wait for the admin email

What is the expected output? What do you see instead?
I expect to see some error about an invalid changelist number and to not get an email to the admin.

Instead I see the "Something Broke!" page and get an email with a traceback ending in: File ".../ReviewBoard-1.5.5-py2.6.egg/reviewboard/reviews/", line 144, in create
    raise ChangeSetError()

TypeError: __init__() takes exactly 2 arguments (1 given)

What operating system are you using? What browser?
The Review Board server is running on Red Hat EL 5.5.
The browser is Chrome 11 beta on Windows 7.

Please provide any additional information below.

I love Review Board, it has been tremendously useful at our company. Keep up the great work!

You received this message because you are subscribed to the Google Groups 
"reviewboard-issues" group.
To post to this group, send email to
To unsubscribe from this group, send email to
For more options, visit this group at

Reply via email to