Status: New
Owner: ----
Labels: Type-Defect Priority-Medium

New issue 2218 by Selecting "This month" in server log viewing section results in HTTP 500 status

* NOTE: Do not post confidential information in this bug report. *
*       If you need immediate support, please contact            *
*                             *

What version are you running?
1.6 RC2

What's the URL of the page containing the problem?

What steps will reproduce the problem?
1. select "Server Log" on the dashboard
2. select "This month" from the Filter/By Date section

What is the expected output? What do you see instead?
Logs for the current month, A 500 error message

What operating system are you using? What browser?
RHEL, Firefox 3

Please provide any additional information below.

It appears, upon initial inspection that the call to calendar.monthrange is returning the tuple (0, 31) for the month of August 2011. calendar.monthrange returns a tuple containing the day of the week (0-6 Mon-Sun) that the month starts on and the number of days in the month. Not the start date (which would be 01 for any month) like the code seems to assume. If we assume that the first day of the month is "1" then we could fix our date formatting by using the "%Y-%m-01" format string instead.

logmsg.txt : Error message received : patch with debugging confirming the output of monthrange
fix.diff.txt : fix

        logmsg.txt  1.0 KB  559 bytes
        fix.diff.txt  536 bytes

You received this message because you are subscribed to the Google Groups 
"reviewboard-issues" group.
To post to this group, send email to
To unsubscribe from this group, send email to
For more options, visit this group at

Reply via email to