Comment #4 on issue 2200 by ReviewBoard cannot accept a new change from Perforce with a description with accent

Now I am sure that there are two errors here. One with the ChangeNumberInUseError, and one with international characters in the Perforce description.
Now I can reconstruct the history around this bug:
- We tried to post-review a change with international characters but we failed by Unicode problems. - Then we re-try the post-review and consistently failed with the mysterious SCMError error I entered originally. - I entered the bug into the tracker. You suggested me the patch for better error reporting. I applied the patch and tried another post-review. Then I hit and reported the Unicode problem again (see comment 3) - Now I hit the SCMError again, and with your patch I located the better error reporting in the log.
Here it is:
Got SCMError when creating review request: None
Traceback (most recent call last):
File "/usr/local/lib/python2.6/dist-packages/ReviewBoard-1.6rc2-py2.6.egg/reviewboard/webapi/", line 5657, in create
    changenum, local_site)
File "/usr/local/lib/python2.6/dist-packages/ReviewBoard-1.6rc2-py2.6.egg/reviewboard/reviews/", line 96, in create
    raise ChangeNumberInUseError(review_request)
ChangeNumberInUseError: None

But to tell the truth, seeing the code I don't understand what is the problem.
Please fix both problems!

You received this message because you are subscribed to the Google Groups 
"reviewboard-issues" group.
To post to this group, send email to
To unsubscribe from this group, send email to
For more options, visit this group at

Reply via email to