Status: New
Owner: ----
Labels: Type-Defect Priority-Medium

New issue 2304 by [Page not found] after upgrade to 1.6.1

* NOTE: Do not post confidential information in this bug report. *
*       If you need immediate support, please contact            *
*                             *

What version are you running?

What's the URL of the page containing the problem?

What steps will reproduce the problem?
1. install ReviewBoard 1.6.1
2. service apache2 restart
3. Browse http://mysite/p4reviewboard/, the page shows incorrect rb-site upgrade command: [rb-site upgrade /usr/local/lib/python2.7/dist-packages/] 4. I ran [rb-site upgrade /usr/local/lib/python2.7/dist-packages/] and then found this command maybe not correct, so I ran again upgrade command as previous upgrade: [rb-site upgrade /var/www/p4reviewboard]

What is the expected output? What do you see instead?
The problem is after I upgrade to 1.6.1, my review board always return "404 Page not found" to any of links to http://mysite/p4reviewboard/.
The error message:
Using the URLconf defined in djblets.util.rooturl, Django tried these URL patterns, in this order:

    ^ ^admin/
    ^ ^media/(?P<path>.*)$
    ^ ^account/
    ^ ^reports/
    ^ ^s/(?P<local_site_name>[A-Za-z0-9\-_.]+)/
    ^ ^$ [name='root']
    ^ ^api/
    ^ ^r/
    ^ ^dashboard/$ [name='dashboard']
    ^ ^users/$ [name='all-users']
    ^ ^users/(?P<username>[A-Za-z0-9@_\-\.]+)/$ [name='user']
^ ^users/(?P<username>[A-Za-z0-9@_\-\.]+)/infobox/$ [name='user-infobox']
    ^ ^groups/$ [name='all-groups']
    ^ ^groups/(?P<name>[A-Za-z0-9_-]+)/$ [name='group']
    ^ ^groups/(?P<name>[A-Za-z0-9_-]+)/members/$ [name='group_members']
    ^ ^account/logout/$ [name='logout']

The current URL, p4reviewboard/, didn't match any of these.

What operating system are you using? What browser?
Ubuntu 11.4, Firefox, chrome

Please provide any additional information below.
I used to upgrade from 1.5 to 1.6 and everything was fine, but this time after upgrade to 1.6.1, my server is totally broken. Even I remove entire reviewboard folder (/var/www/p4reviewboard) and database and use rb-site install to install a new reviewboard, the problem still exist. I also rollback to 1.6 and the problem is still the same. It seems django somehow don't remember the location of mysite's installation path (/var/www/p4reviewboard) so the hint of "rb-site upgrade [path]" is not correct. I also checked my apache2 site-enabled configuration, it's correct as another workable server.

You received this message because you are subscribed to the Google Groups 
"reviewboard-issues" group.
To post to this group, send email to
To unsubscribe from this group, send email to
For more options, visit this group at

Reply via email to