Status: New
Owner: ----
Labels: Type-Defect Priority-Medium

New issue 2568 by j...@jeffmarkham.com: post-review (Perforce) does not work with Perforce brokers
http://code.google.com/p/reviewboard/issues/detail?id=2568

* NOTE: Do not post confidential information in this bug report. *
*       If you need immediate support, please contact            *
*       reviewbo...@googlegroups.com                             *

What version are you running?
2.6


What's the URL of the page containing the problem?
post-review (command line)

What steps will reproduce the problem?
1. Attempt to do a post-review with a Perforce broker/server setup
2.
3.



What is the expected output? What do you see instead?
It is choosing the server instead of the broker

What operating system are you using? What browser?
Linux

Please provide any additional information below.
. In lib/python2.6/site-packages/RBTools-0.4.1-py2.6.egg/rbtools/clients/perforce.py, I made the following change:

From (around line 33):
        m = re.search(r'^Server address: (.+)$', data, re.M)
        if not m:
           return None
To:
        m = re.search(r'^Broker address: (.+)$', data, re.M)
        if not m:
            m = re.search(r'^Server address: (.+)$', data, re.M)
            if not m:
                return None



--
You received this message because you are subscribed to the Google Groups 
"reviewboard-issues" group.
To post to this group, send email to reviewboard-issues@googlegroups.com.
To unsubscribe from this group, send email to 
reviewboard-issues+unsubscr...@googlegroups.com.
For more options, visit this group at 
http://groups.google.com/group/reviewboard-issues?hl=en.

Reply via email to