Comment #8 on issue 2632 by Cannot upload a diff created via svn


I'm having this issue as well. However for me, I am trying to add support for a new repository type (my company's enterprisey repo). I am using the post-review tool, here's the output with --debug

RBTools 0.4.1
Home = /users/phsavoie
acme -ver == true
HTTP GETting api/
HTTP GETting http://ott-pd-vs-001:8000/api/info/
Using the new web API
Attempting to create review request on /nobackup/phsavoie/crs-satellite-431 for None HTTP POSTing to http://ott-pd-vs-001:8000/api/review-requests/: {'repository': '/nobackup/phsavoie/crs-satellite-431'}
Review request created
Uploading diff, size: 124020
HTTP POSTing to http://ott-pd-vs-001:8000/api/review-requests/33/diffs/: {'basedir': '/nobackup/phsavoie/crs-satellite-431'} Got HTTP error: 500: <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"

<html xmlns=""; xml:lang="en" lang="en">
  <title>500 - Internal Server Error | Review Board</title>
  <h1>Something broke! (Error 500)</h1>
   It appears something broke when you tried to go to here. This is either
   a bug in Review Board or a server configuration error. Please report
   this to your administrator.

Error uploading diff

Your review request still exists, but the diff is not attached.

You received this message because you are subscribed to the Google Groups 
"reviewboard-issues" group.
To post to this group, send email to
To unsubscribe from this group, send email to
For more options, visit this group at

Reply via email to