Status: New
Owner: ----
Labels: Type-Defect Priority-Medium

New issue 2657 by xeperis: Reviewboard does not display diff when sourcefile is moved
http://code.google.com/p/reviewboard/issues/detail?id=2657

* NOTE: Do not post confidential information in this bug report. *
*       If you need immediate support, please contact            *
*       reviewbo...@googlegroups.com                             *

What version are you running?
1.6.9 stable

What's the URL of the page containing the problem?
http://[private]

What steps will reproduce the problem?
1. Initiated mercurial repo on bitbucket (https://bitbucket.org/xeperis/test-correct) first made few commits where I modified source files and everything worked after posting review with "hg postreview" 2. Made last commit where I used "hg move" to move file from root to module (pushed changes to repo)
3. executed "hg postreview"
4. followed generated link and clicked on "show diff"

What is the expected output? What do you see instead?
Expected: Display correct diff of changeset
Actual: Error message is displayed


What operating system are you using? What browser?
Windows 7, review board is running on Ubuntu 12.04 LTS

Please provide any additional information below.

Displayed stack trace:
"
Traceback (most recent call last):
File "/usr/local/lib/python2.7/dist-packages/reviewboard/diffviewer/views.py", line 151, in view_diff
    interdiffset, highlighting, True)
File "/usr/local/lib/python2.7/dist-packages/reviewboard/diffviewer/diffutils.py", line 1071, in get_diff_files
    large_data=True)
File "/usr/local/lib/python2.7/dist-packages/djblets/util/misc.py", line 156, in cache_memoize
    data = lookup_callable()
File "/usr/local/lib/python2.7/dist-packages/reviewboard/diffviewer/diffutils.py", line 1070, in <lambda>
    enable_syntax_highlighting)),
File "/usr/local/lib/python2.7/dist-packages/reviewboard/diffviewer/diffutils.py", line 552, in get_chunks
    new = get_patched_file(old, filediff)
File "/usr/local/lib/python2.7/dist-packages/reviewboard/diffviewer/diffutils.py", line 374, in get_patched_file
    return patch(filediff.diff, buffer, filediff.dest_file)
File "/usr/local/lib/python2.7/dist-packages/reviewboard/diffviewer/diffutils.py", line 243, in patch
    (filename, tempdir, patch_output))
Exception: The patch to 'module/src1.txt' didn't apply cleanly. The temporary files have been left in '/tmp/reviewboard.XYGLPa' for debugging purposes.
`patch` returned: patch: **** Only garbage was found in the patch input.
"

I have downloaded "diff" file and attached it "bug (6).patch"

*Everything worked until I moved the one source file*

Attachments:
        bug (6).patch  40 bytes

--
You received this message because you are subscribed to the Google Groups 
"reviewboard-issues" group.
To post to this group, send email to reviewboard-issues@googlegroups.com.
To unsubscribe from this group, send email to 
reviewboard-issues+unsubscr...@googlegroups.com.
For more options, visit this group at 
http://groups.google.com/group/reviewboard-issues?hl=en.

Reply via email to