Status: New
Owner: ----
Labels: Type-Defect Priority-Medium

New issue 2662 by eyuw...@gmail.com: Repository List Resource web service API doesn't return all repos
http://code.google.com/p/reviewboard/issues/detail?id=2662

* NOTE: Do not post confidential information in this bug report. *
*       If you need immediate support, please contact            *
*       reviewbo...@googlegroups.com                             *

What version are you running?
1.6.1

What's the URL of the page containing the problem?
/api/repositories/?start=0&max-results=233

What steps will reproduce the problem?
I have 233 repos in total. Per http://www.reviewboard.org/docs/manual/dev/webapi/2.0/resources/repository-list/, I should get all repos back if I pass in query string max-results, however, it seems the maximum number of repos returned is always 200.

So I'm not able to get the 201th repo in the returned json

To verify the issue, I changed the query string start from 0 to 35. After incrementing the starting index, I can get the 201th repo in the result.


What operating system are you using?
Centos 6


Please provide any additional information below.
It is true that I can get away with this by incrementing the start, but I'm just wondering if you use paginator to implement this feature? and the maximum per page is 200?

If that is the case and you guys don't plan to fix it, please update the API documentation as that limit is not clearly stated.




--
You received this message because you are subscribed to the Google Groups 
"reviewboard-issues" group.
To post to this group, send email to reviewboard-issues@googlegroups.com.
To unsubscribe from this group, send email to 
reviewboard-issues+unsubscr...@googlegroups.com.
For more options, visit this group at 
http://groups.google.com/group/reviewboard-issues?hl=en.

Reply via email to