Status: New
Owner: ----
Labels: Type-Defect Priority-Medium

New issue 2674 by When using Perforce and Changelists, Diff file never generated

* NOTE: Do not post confidential information in this bug report. *
*       If you need immediate support, please contact            *
*                             *

What version are you running?
RBTools 0.4.1
ReviewBoard 1.6.9

What's the URL of the page containing the problem?

The problem is, that it doesn't load the page!

What steps will reproduce the problem?
1. Run this command - from a Cygwin (Unix) shell - for Perforce:
post-review --username=name --password=xxxxx --server=http://reviewboard.quake.local --output-diff --debug --p4-port=darwin:1666 --p4-client=Coding changelistNumber
2.That's it

What is the expected output? What do you see instead?
This is the output, with debug on:
RBTools 0.4.1
Home = C:\Users\mgorga\AppData\Roaming
HTTP GETting api/
HTTP GETting http://reviewboard.quake.local/api/info/
Using the new web API
Warning: //AMAZONAS/branches/Q4000_2.27/modules/QLM/QLM.c in your changeset is unmodified ==== //AMAZONAS/branches/Q4000_2.27/modules/QLM/QLM.c#2 ==M== //AMAZONAS/branches/Q4000_2.27/modules/QLM/QLM.c ====

What operating system are you using? What browser?
Windows 7, Cygwin mintty 1.0.3

Please provide any additional information below.

We are trying to create a diff, based on a changelist, and upload it to the server for review. No matter what we try, we always get back that the changelist is unmodified and no diff was produced. A couple of us have tried this, with the same "warning" - and we know there are multiple differences in the file in the changelist.

You received this message because you are subscribed to the Google Groups 
"reviewboard-issues" group.
To post to this group, send email to
To unsubscribe from this group, send email to
For more options, visit this group at

Reply via email to