Status: New
Owner: ----
Labels: Type-Defect Priority-Medium

New issue 2686 by 1.6.10 breaks svn+ssh for Subversion

What version are you running?

What's the URL of the page containing the problem?
Any page that requests a diff and the respository edit pages.

What steps will reproduce the problem?
1. Take a working 1.6.9 install using Subversion with svn+ssh.
2. Update to 1.6.10 using rb-site script.
3. Attempt to access a review that doesn't have a cached diff which is hosted by a Subversion svn+ssh respository.

What is the expected output? What do you see instead?
The diffs should load.

Rather, the logs display the following:

13:25:32        DEBUG   
SVNTool: Attempting ssh connection with host: ********, username: reviewboard
13:25:32        DEBUG   
starting thread (client mode): 0x92628bd0L
13:25:32        INFO    
Connected (version 2.0, client OpenSSH_5.3p1)
13:25:32        DEBUG   
kex algos:['diffie-hellman-group-exchange-sha256', 'diffie-hellman-group-exchange-sha1', 'diffie-hellman-group14-sha1', 'diffie-hellman-group1-sha1'] server key:['ssh-rsa', 'ssh-dss'] client encrypt:['aes128-ctr', 'aes192-ctr', 'aes256-ctr', 'arcfour256', 'arcfour128', 'aes128-cbc', '3des-cbc', 'blowfish-cbc', 'cast128-cbc', 'aes192-cbc', 'aes256-cbc', 'arcfour', ''] server encrypt:['aes128-ctr', 'aes192-ctr', 'aes256-ctr', 'arcfour256', 'arcfour128', 'aes128-cbc', '3des-cbc', 'blowfish-cbc', 'cast128-cbc', 'aes192-cbc', 'aes256-cbc', 'arcfour', ''] client mac:['hmac-md5', 'hmac-sha1', '', 'hmac-ripemd160', '', 'hmac-sha1-96', 'hmac-md5-96'] server mac:['hmac-md5', 'hmac-sha1', '', 'hmac-ripemd160', '', 'hmac-sha1-96', 'hmac-md5-96'] client compress:['none', ''] server compress:['none', ''] client lang:[''] server lang:[''] kex follows?False
13:25:32        DEBUG   
Ciphers agreed: local=aes128-ctr, remote=aes128-ctr
13:25:32        DEBUG   
using kex diffie-hellman-group1-sha1; server key type ssh-rsa; cipher: local aes128-ctr, remote aes128-ctr; mac: local hmac-sha1, remote hmac-sha1; compression: local none, remote none
13:25:32        DEBUG   
Switch to new keys ...
13:25:32        DEBUG   
Trying SSH key 6d41f76410303cb216b7b8f7c687dab6
13:25:32        DEBUG   
userauth is OK
13:25:32        INFO    
Authentication (publickey) successful!
13:25:32        DEBUG   
EOF in transport thread
13:25:33        ERROR   
SVN: Failed to get repository information for svn+ssh://reviewboard@********/home/svn/repo: Network connection closed unexpectedly
13:25:33        DEBUG   
EOF in transport thread

What operating system are you using? What browser?
Windows, Chrome

Please provide any additional information below.
I downgraded to 1.6.9 by using easy_install to install 1.6.9 and ran the rb-site script against the install. I realize that any database schema changes between 1.6.9 and 1.6.10 will cause other breakage, but when I did this, the svn+ssh connection began working again.

You received this message because you are subscribed to the Google Groups 
"reviewboard-issues" group.
To post to this group, send email to
To unsubscribe from this group, send email to
For more options, visit this group at

Reply via email to