Comment #4 on issue 2686 by 1.6.10 breaks svn+ssh for Subversion

I moved the /var/lib/reviewboard to /var/lib/reviewboard-backup and did a fresh install of 1.6.10 to /var/lib/reviewboard using sqlite as the database. This should ensure that there wasn't anything in my existing database confusing things. I then restarted memcached and apache2.

After going to the install the first time, it informed me that the data directory had the wrong permissions. I ran the command to fix them.

I added a repository and was asked to trust the host. The following error: "Unable to authenticate against this repository using one of the supported authentication types." I copied the old id_rsa over using the following command. I have tested this id_rsa with ssh -i and connected successfully to the svn server.

sudo cp -a /var/lib/reviewboard-backup/data/.ssh/id_rsa /var/lib/reviewboard/data/.ssh/id_rsa

ReviewBoard didn't pick this up, so I downloaded the key from the server and used the ReviewBoard UI to upload the SSH key. This picked up the key. I then tried to add the repository again and saw the following error: "A repository was not found at the specified path."

I went ahead and did the same process described above using ReviewBoard 1.6.9 using "sudo easy_install ReviewBoard==1.6.9" and the rest of the procedure is the same. The result was that no errors were thrown and the repository is added without problems.

You received this message because you are subscribed to the Google Groups 
"reviewboard-issues" group.
To post to this group, send email to
To unsubscribe from this group, send email to
For more options, visit this group at

Reply via email to