Comment #22 on issue 2686 by 1.6.10 breaks svn+ssh for Subversion

I did the following:

$ git clone -b release-0.6.x
$ cd djblets/
$ sudo ./ install
$ sudo service memcached restart
$ sudo service apache2 restart

Unfortunately, I got the same error through the ReviewBoard UI. I ran the same rbssh command you had me run before as the www-data user and got the following output:

/usr/local/lib/python2.6/dist-packages/pycrypto-2.3-py2.6-linux-x86_64.egg/Crypto/Util/ RandomPool_DeprecationWarning: This application uses RandomPool, which is BROKEN in older releases. See
Traceback (most recent call last):
  File "/usr/local/bin/rbssh", line 9, in <module>
    load_entry_point('ReviewBoard==1.6.10', 'console_scripts', 'rbssh')()
File "/usr/lib/python2.6/dist-packages/", line 299, in load_entry_point
    return get_distribution(dist).load_entry_point(group, name)
File "/usr/lib/python2.6/dist-packages/", line 2229, in load_entry_point
    return ep.load()
File "/usr/lib/python2.6/dist-packages/", line 1948, in load
    entry = __import__(self.module_name, globals(),globals(), ['__name__'])
File "/usr/local/lib/python2.6/dist-packages/ReviewBoard-1.6.10-py2.6.egg/reviewboard/cmdline/", line 42, in <module>
    from reviewboard.scmtools import sshutils
File "/usr/local/lib/python2.6/dist-packages/ReviewBoard-1.6.10-py2.6.egg/reviewboard/scmtools/", line 8, in <module>
    from reviewboard.scmtools.errors import AuthenticationError, \
File "/usr/local/lib/python2.6/dist-packages/ReviewBoard-1.6.10-py2.6.egg/reviewboard/scmtools/", line 4, in <module>
    from djblets.util.templatetags.djblets_utils import humanize_list
File "/usr/local/lib/python2.6/dist-packages/Djblets-0.6.21-py2.6.egg/djblets/util/templatetags/", line 31, in <module>
    from django.contrib.auth.models import AnonymousUser, User
File "/usr/local/lib/python2.6/dist-packages/Django-1.3.1-py2.6.egg/django/contrib/auth/", line 7, in <module>
    from django.db import models
File "/usr/local/lib/python2.6/dist-packages/Django-1.3.1-py2.6.egg/django/db/", line 14, in <module>
    if not settings.DATABASES:
File "/usr/local/lib/python2.6/dist-packages/Django-1.3.1-py2.6.egg/django/utils/", line 276, in __getattr__
File "/usr/local/lib/python2.6/dist-packages/Django-1.3.1-py2.6.egg/django/conf/", line 40, in _setup raise ImportError("Settings cannot be imported, because environment variable %s is undefined." % ENVIRONMENT_VARIABLE) ImportError: Settings cannot be imported, because environment variable DJANGO_SETTINGS_MODULE is undefined.

You received this message because you are subscribed to the Google Groups 
"reviewboard-issues" group.
To post to this group, send email to
To unsubscribe from this group, send email to
For more options, visit this group at

Reply via email to