Status: New
Owner: ----
Labels: Type-Defect Priority-Medium

New issue 2720 by thom.ger...@gmail.com: ERROR (EXTERNAL IP): Internal Server Error: /dashboard/
http://code.google.com/p/reviewboard/issues/detail?id=2720

What version are you running?
Relavant versions from$ pip freeze
Django==1.3.2
Djblets==0.6.22
ReviewBoard==1.6.11
Python 2.6.6

Running via WSGI in Apache 2.2.16 on debian.

What's the URL of the page containing the problem?

/dashboard/


What steps will reproduce the problem?

It just happens intermittently for users that have the dashboard open, about once a day out of approximately 3000 GET requests.

Exception output:
Traceback (most recent call last):

File "/usr/local/pythonenv/reviewboard/lib/python2.6/site-packages/django/core/handlers/base.py", line 111, in get_response
   response = callback(request, *callback_args, **callback_kwargs)

File "/usr/local/pythonenv/reviewboard/lib/python2.6/site-packages/djblets/auth/util.py", line 46, in _checklogin
   return view_func(request, *args, **kwargs)

File "/usr/local/pythonenv/reviewboard/lib/python2.6/site-packages/reviewboard/accounts/decorators.py", line 52, in _check_valid_prefs
   return view_func(request, *args, **kwargs)

File "/usr/local/pythonenv/reviewboard/lib/python2.6/site-packages/reviewboard/reviews/views.py", line 807, in dashboard
   return grid.render_to_response(template_name)

File "/usr/local/pythonenv/reviewboard/lib/python2.6/site-packages/djblets/datagrid/grids.py", line 746, in render_to_response
   self.load_state()

File "/usr/local/pythonenv/reviewboard/lib/python2.6/site-packages/djblets/datagrid/grids.py", line 578, in load_state
   self.precompute_objects()

File "/usr/local/pythonenv/reviewboard/lib/python2.6/site-packages/djblets/datagrid/grids.py", line 683, in precompute_objects
   for obj in object_list if obj is not None

File "/usr/local/pythonenv/reviewboard/lib/python2.6/site-packages/djblets/datagrid/grids.py", line 284, in render_cell
   mark_safe(self.datagrid.cell_template_obj.render(ctx))

AttributeError: 'NoneType' object has no attribute 'render'

--
You received this message because you are subscribed to the Google Groups 
"reviewboard-issues" group.
To post to this group, send email to reviewboard-issues@googlegroups.com.
To unsubscribe from this group, send email to 
reviewboard-issues+unsubscr...@googlegroups.com.
For more options, visit this group at 
http://groups.google.com/group/reviewboard-issues?hl=en.

Reply via email to