Status: New
Owner: ----
Labels: Type-Defect Priority-Medium

New issue 2939 by Cannot update diff-- Internal Server Error 500

*** For customer support, please post to
*** If you have a patch, please submit it to
*** Do not post confidential information in this bug report!

What version are you running?

What's the URL of the page containing the problem?

What steps will reproduce the problem?
1. update the diff

What is the expected output? What do you see instead?
Expected the diff to update. Got Internal Server Error 500 instead, which isn't nearly as satisfying.

What operating system are you using? What browser?
RHEL 6.4, Chrome, KDE

Please provide any additional information below.

Here's what post-review gives me. It's essentially the same result as I get if I try to update the diff using the RB web site.

RBTools 0.4 alpha 0 (dev)
Home = /lair/cjohnson
HTTP GETting api/
Using the deprecated Review Board 1.0 web API
==> Review Board Login Required
Enter username and password for Review Board at
Looking for ' /' cookie in /lair/cjohnson/.post-review-cookies.txt
Loaded valid cookie -- no login required
HTTP GETting api/json/reviewrequests/21698/
HTTP GETting api/json/repositories/
HTTP GETting api/json/repositories/1/info/
HTTP GETting api/json/repositories/2/info/
HTTP GETting api/json/repositories/3/info/
HTTP GETting api/json/repositories/4/info/
HTTP GETting api/json/repositories/5/info/
HTTP GETting api/json/repositories/6/info/
HTTP GETting api/json/repositories/7/info/
HTTP GETting api/json/repositories/8/info/
Uploading diff, size: 113208
HTTP POSTing to {'basedir': '/trunk'} Got HTTP error: 500: <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"

<html xmlns=""; xml:lang="en" lang="en">
  <title>500 - Internal Server Error | Review Board</title>
  <h1>Something broke! (Error 500)</h1>
   It appears something broke when you tried to go to here. This is either
   a bug in Review Board or a server configuration error. Please report
   this to your administrator.

Error uploading diff

Your review request still exists, but the diff is not attached.

You received this message because this project is configured to send all issue notifications to this address.
You may adjust your notification preferences at:

You received this message because you are subscribed to the Google Groups 
"reviewboard-issues" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
To post to this group, send email to
Visit this group at
For more options, visit

Reply via email to