Status: New
Owner: ----
Labels: Type-Defect Priority-Medium

New issue 2996 by gros...@gmail.com: Reports page should escape [ and ] characters
http://code.google.com/p/reviewboard/issues/detail?id=2996

What version are you running?

1.6.13

What's the URL of the page containing the problem?

https://reviewboard.eng.vmware.com/reports/<my_username>/review/moinmoin/

What steps will reproduce the problem?
1. Have someone post to you a review containing [] in the title
2. Open the MoinMoin reviewboard reports page

What is the expected output? What do you see instead?

I would expect the [ and ] characters in the title to be escaped so they don't prematurely end the link formatting. Instead, I see something like:

== Code Reviews Done ==
. [https://<review_link> [blah]blahblahblah by somedude]

which doesn't work very well in the wiki.

What operating system are you using? What browser?

Chrome 28 on Windows 7.

Please provide any additional information below.

--
You received this message because this project is configured to send all issue notifications to this address.
You may adjust your notification preferences at:
https://code.google.com/hosting/settings

--
You received this message because you are subscribed to the Google Groups 
"reviewboard-issues" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to reviewboard-issues+unsubscr...@googlegroups.com.
To post to this group, send email to reviewboard-issues@googlegroups.com.
Visit this group at http://groups.google.com/group/reviewboard-issues?hl=en.
For more options, visit https://groups.google.com/groups/opt_out.


Reply via email to