Status: New
Owner: ----
Labels: Type-Defect Priority-Medium

New issue 3193 by dpr...@gmail.com: RBTools 0.5.5 drops Python 2.4 compatibility
http://code.google.com/p/reviewboard/issues/detail?id=3193

*** READ THIS BEFORE POSTING!
***
*** You must complete this form in its entirety, or your bug report will be
rejected.
***
*** For customer support, please post to reviewbo...@googlegroups.com
***
*** If you have a patch, please submit it to
http://reviews.reviewboard.org/
***
*** Do not post confidential information in this bug report!


What version are you running?
0.5.5

What steps will reproduce the problem?
1. Byte compile rbtools using Python 2.4
2. Error will be raised on setup_repo.py

What is the expected output? What do you see instead?
File "/usr/lib/python2.4/site-packages/rbtools/commands/setup_repo.py", line 100
    except IOError as e:
                    ^
SyntaxError: invalid syntax

What operating system are you using? What browser?
RHEL 5.9 (64-bit)

Please provide any additional information below.
This appears to be the only location in the code where new exception raising syntax is used. Reertins this file to use the old method should bring back compatibility with Python 2.4 and later.

--
You received this message because this project is configured to send all issue notifications to this address.
You may adjust your notification preferences at:
https://code.google.com/hosting/settings

--
You received this message because you are subscribed to the Google Groups 
"reviewboard-issues" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to reviewboard-issues+unsubscr...@googlegroups.com.
To post to this group, send email to reviewboard-issues@googlegroups.com.
Visit this group at http://groups.google.com/group/reviewboard-issues.
For more options, visit https://groups.google.com/groups/opt_out.

Reply via email to