Status: New
Owner: ----
Labels: Type-Defect Priority-Medium

New issue 3265 by f...@esss.com.br: reviewboard with apache mod_proxy
http://code.google.com/p/reviewboard/issues/detail?id=3265

*** READ THIS BEFORE POSTING!
***
*** You must complete this form in its entirety, or your bug report will be
rejected.
***
*** For customer support, please post to reviewbo...@googlegroups.com
***
*** If you have a patch, please submit it to
http://reviews.reviewboard.org/
***
*** Do not post confidential information in this bug report!


What version are you running?
1.7.21


What's the URL of the page containing the problem?

https://eden.esss.com.br (external) but the problem occur only in "Ship it" button

http://flinsvm012.fln.esss.com.br (internal) if accessed directly it works at all.

What steps will reproduce the problem?
Login in https://eden.esss.com.br choose a review request and clic in Ship it, will appear a message "A server error occurred.Show Details Dismiss" In details link open a window with the follow messages, see that request URL was redirected to internal URL and that is inaccessible to internet:

Error Code: 0

Error Text: error

Request URL: http://flinsvm012.fln.esss.com.br/reviewboard/api/review-requests/40243/reviews/draft/

Request Data: (none)

Response Data:

There may be useful error details below. The following error page may be useful to your system administrator or when reporting a bug. To save the page, right-click the error below and choose "Save Page As," if available, or "View Source" and save the result as a .html file.

Warning: Be sure to remove any sensitive material that may exist in the error page before reporting a bug!

What is the expected output? What do you see instead?
Expected was ship review to reviewers

What operating system are you using? What browser?
Centos 6, Chrome Version 32.0.1700.107

Please provide any additional information below.

In the apache log of reviewboard, bellow, I see that reviewboard changed response to browser, the 10.0.0.1 is server apache with mod_proxy and with internet valid IP, when the error occur the reviewboard return to my local machine 10.0.0.118, I think in some place reviewboard is sending to browser the information about internal address and not the server address configured on General Settings.


10.0.0.1 - - [25/Feb/2014:10:57:20 +0000] "GET /reviewboard/api/review-requests/40243/?api_format=json HTTP/1.1" 200 599 "https://eden.esss.com.br/reviewboard/r/40243/"; "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/32.0.1700.107 Safari/537.36" 10.0.0.118 - - [25/Feb/2014:10:57:20 +0000] "GET /reviewboard/api/review-requests/40243/reviews/draft/?api_format=json HTTP/1.1" 401 70 "-" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/32.0.1700.107 Safari/537.36"


Thanks for advance


--
You received this message because this project is configured to send all issue notifications to this address.
You may adjust your notification preferences at:
https://code.google.com/hosting/settings

--
You received this message because you are subscribed to the Google Groups 
"reviewboard-issues" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to reviewboard-issues+unsubscr...@googlegroups.com.
To post to this group, send email to reviewboard-issues@googlegroups.com.
Visit this group at http://groups.google.com/group/reviewboard-issues.
For more options, visit https://groups.google.com/groups/opt_out.

Reply via email to