Status: New
Owner: ----
Labels: Type-Defect Priority-Medium

New issue 3327 by When composing a review, comment text is not properly synchronized between the inline editor and the full-window editor

What version are you running?
1.7.6. This issue also reproduces with the 2.0 RC2 instance deployed on

What's the URL of the page containing the problem?

What steps will reproduce the problem?
1. Add a new comment with the inline editor and press "Save".
2. Open the full-screen editor by clicking "Edit Review" in the green bar at the top of the page. See that the comment is there.
3. Edit the text for the comment.
4. Click "Save" in the full-screen editor.
5. Hover over the green icon on the line where you previously added the comment. Observe that the content shown in the tooltip is stale. 6. Click on the green icon on the line where you previously added the comment. Observe that the content of the inline editor is also stale.

What is the expected output? What do you see instead?
I expected to see my modified comment content. Instead, I saw stale comment text. It wasn't synchronized between the two editors properly.

What operating system are you using? What browser?
Linux (Debian). Tested with both Firefox 27.0 and Firefox 25.0.

Please provide any additional information below.
Note that the text synchronization is only broken in one direction (i.e., edits made in the inline editor will always be properly reflected in the full-screen editor).

You received this message because this project is configured to send all issue notifications to this address.
You may adjust your notification preferences at:

You received this message because you are subscribed to the Google Groups 
"reviewboard-issues" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
To post to this group, send email to
Visit this group at
For more options, visit

Reply via email to