Comment #1 on issue 3518 by alex...@gmail.com: Can't upload review due to UnicodeDecodeError
http://code.google.com/p/reviewboard/issues/detail?id=3518

I confirm this issue. It is reproduced on Windows OSes too.
The bug is regression against the previous major release version 1.7.x
The bug occurs when a file in SVN contains any non-ASCII symbol and diff uploads against such file. At the same time, diff with non-ASCII symbols can be uploaded.

mysql settings:
mysql> SHOW VARIABLES WHERE variable_name IN ('character_set_database', 'collation_database');
+------------------------+-----------------+
| Variable_name          | Value           |
+------------------------+-----------------+
| character_set_database | utf8            |
| collation_database     | utf8_unicode_ci |
+------------------------+-----------------+
2 rows in set (0.00 sec)

--
You received this message because this project is configured to send all issue notifications to this address.
You may adjust your notification preferences at:
https://code.google.com/hosting/settings

--
You received this message because you are subscribed to the Google Groups 
"reviewboard-issues" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to reviewboard-issues+unsubscr...@googlegroups.com.
To post to this group, send email to reviewboard-issues@googlegroups.com.
Visit this group at http://groups.google.com/group/reviewboard-issues.
For more options, visit https://groups.google.com/d/optout.

Reply via email to