Status: New
Owner: ----
Labels: Type-Defect Priority-Medium

New issue 3594 by emcwee...@gmail.com: User from Argentina unable to login: Time Zone Error
https://code.google.com/p/reviewboard/issues/detail?id=3594

*** READ THIS BEFORE POSTING!
***
*** You must complete this form in its entirety, or your bug report will be
*** rejected.
***
*** If you have a security issue to report, please send it confidentially
to
*** secur...@reviewboard.org. Posting security-related issues to this bug
*** tracker causes us to have to do an emergency release.
***
*** For customer support, please post to reviewbo...@googlegroups.com
***
*** If you have a patch, please submit it to
http://reviews.reviewboard.org/
***
*** This bug tracker is public. Please check that any logs or other
information
*** that you include has been stripped of confidential information.


What version are you running?
1.7.5

What's the URL of the page containing the problem?
not available to the public, internal only.

What steps will reproduce the problem?
1.go to url
2.login with user credentials (Argentina user)

What is the expected output? What do you see instead?
Normally the user sees their open/closed review requests.

Instead we get:

""Something broke! (Error 500)

It appears something broke when you tried to go to here. This is either a bug in Review Board or a server configuration error. Please report this to your administrator.""

Instead
What operating system are you using? What browser?
Google Chrome/Windows 7
Google Chrome Mac OS X

Please provide any additional information below.
running reviewboard on CentOS release 6.3 (Final) 32 bit.

I am the administrator and I get the following error email message. Notice the Time Zone Error:

Traceback (most recent call last):

File "/usr/lib/python2.6/site-packages/Django-1.4.3-py2.6.egg/django/core/handlers/base.py", line 89, in get_response
    response = middleware_method(request)

File "/usr/lib/python2.6/site-packages/ReviewBoard-1.7.5-py2.6.egg/reviewboard/accounts/middleware.py", line 13, in process_request
    timezone.activate(pytz.timezone(user.timezone))

File "/usr/lib/python2.6/site-packages/pytz-2012j-py2.6.egg/pytz/__init__.py", line 185, in timezone
    raise UnknownTimeZoneError(zone)

UnknownTimeZoneError: 'America/Argentina/Me'


This has been working for years. Let me know if this raises any flags for anybody.


--
You received this message because this project is configured to send all issue notifications to this address.
You may adjust your notification preferences at:
https://code.google.com/hosting/settings

--
You received this message because you are subscribed to the Google Groups 
"reviewboard-issues" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to reviewboard-issues+unsubscr...@googlegroups.com.
To post to this group, send email to reviewboard-issues@googlegroups.com.
Visit this group at http://groups.google.com/group/reviewboard-issues.
For more options, visit https://groups.google.com/d/optout.

Reply via email to