Status: New
Owner: ----
Labels: Type-Defect Priority-Medium

New issue 3606 by "Edit" button appears next to image titles that the user doesn't have permission to edit

What version are you running?
2.0.6. This also reproduces with the version deployed on the demo site (2.1 alpha 0).

What's the URL of the page containing the problem?

What steps will reproduce the problem?
1. Visit a review not posted by you that has images attached. (e.g. assuming you're not logged in as 'chipx86') 2. Note that an "edit" button appears next to the title of each image attachment, even though you are lacking permissions to edit the titles.

What is the expected output? What do you see instead?
The edit button should not appear.

What operating system are you using? What browser?
Linux; Firefox 29.0 and Firefox 30.0 both show this issue.

Please provide any additional information below.
Actually attempting to edit the image titles first shows the new title you input, but the edit is rejected server-side. Refreshing the page will restore the title of the image to whatever it was before.

You received this message because this project is configured to send all issue notifications to this address.
You may adjust your notification preferences at:

You received this message because you are subscribed to the Google Groups 
"reviewboard-issues" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
To post to this group, send email to
Visit this group at
For more options, visit

Reply via email to