Status: New
Owner: ----
Labels: Type-Defect Priority-Medium

New issue 3629 by erik.l...@gmail.com: auto-completion regression in 2.0.8
https://code.google.com/p/reviewboard/issues/detail?id=3629

*** READ THIS BEFORE POSTING!
***
*** You must complete this form in its entirety, or your bug report will be
*** rejected.
***
*** If you have a security issue to report, please send it confidentially
to
*** secur...@reviewboard.org. Posting security-related issues to this bug
*** tracker causes us to have to do an emergency release.
***
*** For customer support, please post to reviewbo...@googlegroups.com
***
*** If you have a patch, please submit it to
http://reviews.reviewboard.org/
***
*** This bug tracker is public. Please check that any logs or other
information
*** that you include has been stripped of confidential information.


What version are you running?
2.0.8

What's the URL of the page containing the problem?
N/A


What steps will reproduce the problem?
1. Create a new review request draft
2. Edit a field that has auto-completion (i.e. the Reviewers Groups field)
3. As you type, you will see an auto-completion box, if what you are typing is an exact match of the review group name (include matching case) then hitting tab will autocomplete your string and everything is fine. However, if the case is incorrect or if you are typing the Group Name (not the GroupID) then hitting tab will *not* autocomplete your text and you will be left with what you have already typed and the auto-complete drop-down will close.

What is the expected output? What do you see instead?
Hitting tab should erase the text that you entered and fill it in with the correct string, instead this only occurs for the simple case (where what you are autocomplete is an exact prefix of what you are trying to complete).


What operating system are you using? What browser?
OS X; Chrome


Please provide any additional information below.

I see that 03ea5b8e04c82d29dd6a750ff9122e283e2bdf44 was committed on the 2.0.x branch but hasn't been released yet. I haven't had a chance yet to validate that it does indeed fix the problem that I mentioned. If it does excellent! otherwise I wanted to make sure a proper bug was reported.

--
You received this message because this project is configured to send all issue notifications to this address.
You may adjust your notification preferences at:
https://code.google.com/hosting/settings

--
You received this message because you are subscribed to the Google Groups 
"reviewboard-issues" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to reviewboard-issues+unsubscr...@googlegroups.com.
To post to this group, send email to reviewboard-issues@googlegroups.com.
Visit this group at http://groups.google.com/group/reviewboard-issues.
For more options, visit https://groups.google.com/d/optout.

Reply via email to