Status: New
Owner: ----
Labels: Type-Defect Priority-Medium

New issue 3694 by AJAX call not working in Chrome

What version are you running?


What's the URL of the page containing the problem?


What steps will reproduce the problem?
1. Take an action that involves an AJAX call, for example, mark an issue as "Fixed".

What is the expected output? What do you see instead?

In this example, I expect to see an AJAX PUT or POST and then a transition to "The issue has been resolved." Instead, in Chrome, I see a GET request to "/api/review-requests/1911/?api_format=json", then the "Fixed" and "Drop" buttons are disabled and nothing else happens. Similar results with other AJAX mechanisms, like posting a new comment. Problem does not occur with Firefox or others using the same server who are using Chrome.

What operating system are you using? What browser?

W7, Chrome 39.0.2171.71 m

Please provide any additional information below.

Request header from Chrome:

GET /api/review-requests/1911/?api_format=json HTTP/1.1
Connection: keep-alive
Accept: text/xml,application/xhtml+xml,application/xml;q=0.9,image/webp,*/*;q=0.8
X-Requested-With: XMLHttpRequest
User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/39.0.2171.71 Safari/537.36
Accept-Encoding: gzip, deflate, sdch
Accept-Language: en-US,en;q=0.8
Cookie: csrftoken=ENCSO0HSXfyAdACh9E0o8dCJHyHckXU5; rbsessionid=mant5fmzdwxw2tk6xy22jlvulqur4bvh

You received this message because this project is configured to send all issue notifications to this address.
You may adjust your notification preferences at:

You received this message because you are subscribed to the Google Groups 
"reviewboard-issues" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
To post to this group, send email to
Visit this group at
For more options, visit

Reply via email to