Status: New
Owner: ----
Labels: Type-Defect Priority-Medium

New issue 3835 by AttributeError: 'NoneType' object has no attribute 'get' in reviewboard\admin\", line 39

What version are you running?

What's the URL of the page containing the problem?

What steps will reproduce the problem?
1. Login with a local administrator (staff)
2. Go to Admin page

What is the expected output? What do you see instead?
Admin page should be displayed, but instead
"Something broke! (Error 500)"

What operating system are you using? What browser?
Windows Server 2008 R2 english, Chrome

Please provide any additional information below.
Traceback (most recent call last):

File "D:\Programs\Python27\lib\site-packages\django-1.6.11-py2.7.egg\django\core\handlers\", line 112, in get_response
    response = wrapped_callback(request, *callback_args, **callback_kwargs)

File "D:\Programs\Python27\lib\site-packages\django-1.6.11-py2.7.egg\django\contrib\admin\views\", line 17, in _checklogin
    return view_func(request, *args, **kwargs)

File "D:\Programs\Python27\lib\site-packages\reviewboard-2.0.15-py2.7.egg\reviewboard\admin\", line 39, in dashboard
    primary_widget_positions = profile_data.get('primary_widget_positions')

AttributeError: 'NoneType' object has no attribute 'get'

I have no clue, why profile_data is None.

Also, when logging in with an LDAP Admin, the page works.
Seems to be something missing when create a new Admin account?

Thanks for your help.

You received this message because this project is configured to send all issue notifications to this address.
You may adjust your notification preferences at:

You received this message because you are subscribed to the Google Groups 
"reviewboard-issues" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
To post to this group, send email to
Visit this group at
For more options, visit

Reply via email to