Sorry, forgot to answer your specific questions:

Django version: 1.0
OS: Windows XP
Python 2.5

I'm setting this up in Cygwin.  I downloaded the reviewboard stuff via
the svn command directly into C:/ and I installed all of the other
requirements by following the Getting Started guide (nice and
helpful!).   I upgraded from Apache 1.3 (cygwin) to Apache 2.0
(windows), but I'm not using Apache yet since I'm still having trouble
with the basic install (though I did get mod_python working, but not
mod_fastcgi).


Thanks for all the help!


Dan

On Sep 16, 4:17 pm, "Christian Hammond" <[EMAIL PROTECTED]> wrote:
> I completely understand your frustration. This is certainly a new issue that
> I've not seen before. Can't imagine why syncdb would be hanging like this.
> How long have you given it?
>
> Also, what version of Django do you have installed, and what OS/distro is
> this on? What version of Python?
>
> When you press Control-C when doing the syncdb, does it display any
> backtrace information? Can you show us a complete dump of the output of your
> syncdb?
>
> Installation is one of our main weak points. I'm working on getting this all
> simplified where you have basically two commands to get Review Board
> running: one for installing Review Board and its main dependencies, and one
> for setting up the site/database. These aren't in yet so they won't benefit
> you, but just letting you know we are working on it. However, this syncdb
> thing seems to be pretty specific to your setup.
>
> Christian
>
> --
> Christian Hammond - [EMAIL PROTECTED]
> VMware, Inc.
>
> On Tue, Sep 16, 2008 at 4:09 PM, wex <[EMAIL PROTECTED]> wrote:
>
> > I seem to have the same basic issue when I try to use sqlite3 instead
> > of mysql.
>
> > I updated settings_local.py to use sqlite3, specified the database as
> > "reviewboard.sqlite" and tried to run "./manage.py syncdb".
>
> > Once again it hangs.  If I interrupt it, I can see that it created the
> > reviewboard.sqlite database in the local directory, but it never asked
> > me for an admin user/pass.  Ugh!
>
> > Perhaps some directory is not writable or there is some other
> > permissions issue?
>
> > This is killing me.  I'm trying to switch from using Code Collaborator
> > to Reviewboard, and I've now spent about 10 hours trying to get it set
> > up.  Incredibly frustrating.  I'd love to get all of NVIDIA using
> > reviewboard...
>
> > On Sep 16, 3:52 pm, wex <[EMAIL PROTECTED]> wrote:
> > > Thanks for the tips, but still no dice.
>
> > > The Getting Started docs explicitly say that you need to create a
> > > database when using mysql (see the "Database" section).  If you don't
> > > create a database, you get the following error when running "manage.py
> > > syncdb":
>
> > >   ...
> > >   File "c:\reviewboard\__init__.py", line 74, in Connect
> > >   File "build\bdist.win32\egg\MySQLdb\connections.py", line 170, in
> > > __init__
> > > _mysql_exceptions.OperationalError: (1049, "Unknown database
> > > 'reviewboard'")
>
> > > I'm not particularly married to using mysql, it was just that it was
> > > already installed on my machine.  Is all this easier with sqlite?
>
> > > On Sep 16, 3:46 pm, "David Trowbridge" <[EMAIL PROTECTED]> wrote:
>
> > > > I don't think you even need to create the database in mysql before
> > > > running syncdb--in fact, its existence may confuse syncdb into
> > > > thinking it's not the first-time run.
>
> > > > -David
>
> > > > On Tue, Sep 16, 2008 at 3:40 PM, wex <[EMAIL PROTECTED]> wrote:
>
> > > > > Thanks.  Good information.  That will keep me from spending any more
> > > > > time messing with my ADMINS or basic users.
>
> > > > > I've deleted the database using the mysql command "drop database
> > > > > reviewboard" and then I created it again from scratch using "create
> > > > > database reviewboard" and now, when I issue "manage.py syncdb" it
> > just
> > > > > hangs (just like I got with I tried doing "manage.py
> > > > > createsuperuser").  I must have something messed up in my mysql
> > config
> > > > > that is messing up the superuser creation.
>
> > > > > If I interrupt the initial "manage.py syncdb" (after about five
> > > > > minutes of it just hanging).  I can see that, once again, I have a
> > > > > bunch of tables in my db, but my admin stuff is still not there.  I'm
> > > > > pretty sure this is the same thing that happened to me the first
> > time.
>
> > > > > That's a bit odd, since it indicates that manage.py is able to create
> > > > > tables in my database (so it has access), but something else is
> > > > > preventing it from creating the admin stuff?
>
> > > > > Hmmm.
>
> > > > > On Sep 16, 3:22 pm, "Christian Hammond" <[EMAIL PROTECTED]> wrote:
> > > > >> I would say your best bet is to just nuke your current database and
> > re-run
> > > > >> syncdb. It definitely should be asking for a user/pass.
>
> > > > >> The way admins work is that you have a User entry in the database
> > with the
> > > > >> Superuser and Admin flags set. This allows you to log into the admin
> > UI. The
> > > > >> MySQL password has nothing to do with users in Review Board/Django,
> > nor does
> > > > >> the ADMINS line in settings.py.
>
> > > > >> Christian
>
> > > > >> --
> > > > >> Christian Hammond - [EMAIL PROTECTED]
> > > > >> VMware, Inc.
>
> > > > >> On Tue, Sep 16, 2008 at 3:09 PM, wex <[EMAIL PROTECTED]> wrote:
>
> > > > >> > Aha, this looks like a Django user/pass.  Browsing the django
> > manual,
> > > > >> > it seems as though I should run "manage.py createsuperuser",
> > > > >> > but when I do that, it just hangs.  Sigh.  I'll bet that happened
> > as I
> > > > >> > was configuring things, and I just did a Ctrl-C to break out and
> > fix
> > > > >> > stuff.
>
> > > > >> > Any clue as to how to debug the hang I get with "manage.py
> > > > >> > createsuperuser"?
>
> > > > >> > I guess I'll keep paging through the Django docs...
>
> > > > >> > On Sep 16, 2:50 pm, "David Trowbridge" <[EMAIL PROTECTED]>
> > wrote:
> > > > >> > > When you run './manage.py syncdb', it should ask you for a
> > username
> > > > >> > > and password for the admin.
>
> > > > >> > > -David
>
> > > > >> > > On Tue, Sep 16, 2008 at 2:18 PM, wex <[EMAIL PROTECTED]>
> > wrote:
>
> > > > >> > > > Is there any log file I can examine to try and debug this
> > admin login
> > > > >> > > > issue?
>
> > > > >> > > > On Sep 16, 2:06 pm, wex <[EMAIL PROTECTED]> wrote:
> > > > >> > > >> The Reviewboard Getting Started guide instructions do not
> > require a
> > > > >> > > >> user/pass for anything other than MySQL.   I've tried that
> > and it
> > > > >> > > >> doesn't work.
>
> > > > >> > > >> Is the admin password supposed to match the mysql user/pass?
> >  Do I
> > > > >> > > >> need to enter this information into settings.py or only in
> > > > >> > > >> settings_local.py?
>
> > > > >> > > >> I've tried all sorts of user/pass combinations in settings.py
> > and with
> > > > >> > > >> my MySQL database.  None of them work.  Tips appreciated!
>
> > > > >> > > >> On Sep 16, 1:52 pm, "Joseph Liu" <[EMAIL PROTECTED]> wrote:
>
> > > > >> > > >> > It should be the user/pass when you set up reviewboard.
>
> > > > >> > > >> > On Tue, Sep 16, 2008 at 12:41 PM, wex <[EMAIL PROTECTED]>
> > wrote:
>
> > > > >> > > >> > > How do I configure the admin login?
>
> > > > >> > > >> > > I get invalid username/password messages every time I try
> > to log
> > > > >> > in to
> > > > >> > > >> > > the reviewboard/admin page.
>
> > > > >> > > >> > > I'm using a MySQL database on a Windows XP server.  I've
> > tried
> > > > >> > lots of
> > > > >> > > >> > > different values in the settings.py ADMIN field, but I
> > can't get
> > > > >> > it to
> > > > >> > > >> > > work.  What values go in the settings.py ADMIN field?
> >  Are there
> > > > >> > other
> > > > >> > > >> > > configuration settings I need to change to get my admin
> > accounts
> > > > >> > set
> > > > >> > > >> > > up?
>
> > > > >> > > >> > > I can log in to my MySQL command line client.  Checking
> > the status
> > > > >> > in
> > > > >> > > >> > > MySQL indicates that I'm logged in with the Current user
> > set to
> > > > >> > > >> > > "[EMAIL PROTECTED]"
>
> > > > >> > > >> > > Apologies, I know next to nothing about MySQL.
>
> > > > >> > > >> > > Thanks,
>
> > > > >> > > >> > > Dan Wexler
--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups 
"reviewboard" group.
To post to this group, send email to reviewboard@googlegroups.com
To unsubscribe from this group, send email to [EMAIL PROTECTED]
For more options, visit this group at 
http://groups.google.com/group/reviewboard?hl=en
-~----------~----~----~----~------~----~------~--~---

Reply via email to