Searching the old posts, looks like this is probably some sort of
apache configuration error on my part.  However, I don't see any
errors in the apache log, but I do see two requests for the post, one
for /api/json/accounts/login/ (which looks like it succeeds) and
another for /api/json/reviewrequests/new/ which fails.

Any suggestions on what might be wrong with my apache server config?


On Sep 17, 1:51 pm, Daniel Wexler <[EMAIL PROTECTED]> wrote:
> Almost got everything working, but I'm still having some trouble with
> post-review.  Looks like the diff is now being created properly and
> most interactions with the server are ok (it creates a new review),
> but the files are not uploaded and I get the following error:
>
> Unable to accesshttp://maki/api/json/reviewrequests/new/. The host
> path may be invalid
> HTTP Error 500: Internal Server Error
>
> I've tried creating an "api/json/reviewrequests/new/" directory within
> the htdocs in my reviewboard directory on the server, and changing the
> permissions to allow the web server to write to it, but no dice.
> Looks like this is happening at line post-review.py:403.
>
> If I try to access that directory from another machine, with
> PythonDebug enabled, I get a Page Not Found error with a bit more info
> from Django:
>
> Using the URLconf defined in djblets.util.rooturl, Django tried these
> URL patterns, in this order:
> ^ ^admin/
> ^ ^media/(?P<path>.*)$
> ^ ^account/
> ^ ^api/json/
> ^ ^r/
> ^ ^reports/
> ^ ^dashboard/$
> ^ ^users/$
> ^ ^users/(?P<username>[A-Za-z0-9_\-\.]+)/$
> ^ ^groups/$
> ^ ^groups/(?P<name>[A-Za-z0-9_-]+)/$
> ^ ^groups/(?P<name>[A-Za-z0-9_-]+)/members/$
> ^ ^feeds/rss/(?P<url>.*)/$
> ^ ^feeds/atom/(?P<url>.*)/$
> ^ ^account/logout/$
> ^ ^$
> ^ ^iphone/
> The current URL, app/, didn't match any of these.
>
> Suggestions?
>
> Do I need to add something to my Apache httpd.conf file?  I've even
> tried creating that path in both the Apache and reviewboard htdocs
> directories and putting a bogus file there, but Django/Apache are
> intercepting those requests and printing that special 404 page.
>
> I'm tantalizingly close to having everything working (database,
> apache, mod_perl all good now), I made it through a few post-review
> issues (getting a diff program in my path, setting my P4PORT &
> P4CLIENT env vars, changing the repository path on the server,...).  I
> can feel that I'm close now after two full days of setup!
--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups 
"reviewboard" group.
To post to this group, send email to reviewboard@googlegroups.com
To unsubscribe from this group, send email to [EMAIL PROTECTED]
For more options, visit this group at 
http://groups.google.com/group/reviewboard?hl=en
-~----------~----~----~----~------~----~------~--~---

Reply via email to