In the admin section of reviewboard you have to set up your repositories.
For perforce it asks for a user name and a password.  When i used my
password i received the same error that you are getting.  I fixed it by
using my ticket number instead.  Every time a user logs into Perforce they
are assigned a ticket.  You can see yours by using "p4 login -p".  You can
also allow this ticket to be valid on multiple clients by adding "-a".
There for login in to perforce using "p4 login -a -p" and try using the
ticket number given in the reviewboard repository list.

On Wed, Sep 24, 2008 at 10:02 AM, 13Strider <[EMAIL PROTECTED]>wrote:

>
> can you be more descriptive ?
>
> On Sep 23, 5:59 pm, Joshua Slominski <[EMAIL PROTECTED]> wrote:
> > I got this error when I was putting my p4 password in the repository
> > list. I fixed it buy using the p4 ticket. You can get that by running
> > p4 login -a -p.
> >
> > Sent from my iPhone
> >
>  > On Sep 23, 2008, at 2:27 PM, 13Strider <[EMAIL PROTECTED]>
> wrote:
> >
> >
> >
> > > Any Idia why a i getting this error ?
> >
> > > P4Exception at /api/json/reviewrequests/new/
> >
> > > [P4#run] Errors during command execution( "p4 describe -s 79737" )
> >
> > >    [Error]: .
> >
> > > Request Method:    POST Perforce password (P4PASSWD) invalid or unset
> > > Request URL:    http://192.168.9.176:8000/api/json/reviewrequests/new/
> > > Exception Type:    P4Exception
> > > Exception Value:
> >
> > > [P4#run] Errors during command execution( "p4 describe -s 79737" )
> >
> > >    [Error]: Perforce password (P4PASSWD) invalid or unset.
> >
> > > Exception Location:    /var/www/reviewboard/scmtools/perforce.py in
> > > get_changeset, line 57
> > > Python Executable:    /usr/bin/python
> > > Python Version:    2.5.1
> > > Python Path:    ['/var/www', '/var/www/reviewboard', '/usr/lib/
> > > python2.5/
> > > site-packages/simplejson-1.9.2-py2.5-linux-i686.egg', '/usr/lib/
> > > python2.5/site-packages/python_memcached-1.43-py2.5.egg', '/usr/lib/
> > > python2.5/site-packages/nose-0.10.1-py2.5.egg', '/usr/lib/python2.5/
> > > site-packages/coverage-2.80-py2.5.egg', '/usr/lib/python25.zip', '/
> > > usr/
> > > lib/python2.5', '/usr/lib/python2.5/plat-linux2', '/usr/lib/python2.5/
> > > lib-tk', '/usr/lib/python2.5/lib-dynload', '/usr/lib/python2.5/site-
> > > packages', '/usr/lib/python2.5/site-packages/Numeric', '/usr/lib/
> > > python2.5/site-packages/PIL', '/usr/lib/python2.5/site-packages/
> > > gst-0.10', '/usr/lib/python2.5/site-packages/gtk-2.0']
> > > Server time:    Tue, 23 Sep 2008 10:56:56 -0700
> >
>

--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups 
"reviewboard" group.
To post to this group, send email to reviewboard@googlegroups.com
To unsubscribe from this group, send email to [EMAIL PROTECTED]
For more options, visit this group at 
http://groups.google.com/group/reviewboard?hl=en
-~----------~----~----~----~------~----~------~--~---

Reply via email to